summaryrefslogtreecommitdiff
path: root/app-text/recode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-text/recode
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/Manifest4
-rw-r--r--app-text/recode/recode-3.7.11.ebuild59
-rw-r--r--app-text/recode/recode-3.7.9.ebuild4
3 files changed, 64 insertions, 3 deletions
diff --git a/app-text/recode/Manifest b/app-text/recode/Manifest
index fc0dfd6f5a4f..b521611d09d7 100644
--- a/app-text/recode/Manifest
+++ b/app-text/recode/Manifest
@@ -1,3 +1,5 @@
+DIST recode-3.7.11.tar.gz 2405035 BLAKE2B 363499d265c201e9c8c4be0821efd9900e72aa21aee2e6f77ea85b5a31afb43a905eb5a88cbf1be0fd40bdc44f8707b24fe5a896cd645f5674ae69027bd167a9 SHA512 b00be87c321f5fef6aa0a7813f97b2368cbcac28f0c9e856b81e84ff878689428e1ca079a255ad44beecdcdf6efc7406517fa3116f12886bcc421b323e3810ce
DIST recode-3.7.9.tar.gz 2230259 BLAKE2B 36039ba9e62c5113231764dfa9cffa73b7ff5cd91bab622a0daf0a48a73ab8a62afd16132cec2590eed14623ce5b86ad057e8ca8454cf8185869f0780b3523e7 SHA512 277074dee63cdc7f1a1be2acca67481b8fb816bd4319fe8e882696e42d15309750b930fa9e8d6286e714132a976f0eaf87f718560d6cb86eeaa79b86f0700a6c
-EBUILD recode-3.7.9.ebuild 1308 BLAKE2B 1d563895a5a28120b51384b8003185967a255c3d5147909b32c07e1021c7f884c054eba5f05844ba16e818547f7d995199dcf3908da38cf87ad9215ae109509c SHA512 b297ec5032cb8d23b05117cbb50ea14f6675fec15076aeb0431c9efe8f6c177318c7d2f18d9cdcc552c95b121b5e135c4a6882963b0c77ad3a3967bd9af92238
+EBUILD recode-3.7.11.ebuild 1316 BLAKE2B 5eb3d2a848d845b971889e8016a28b0bb1b15e6fb5afaea150637f37966c04d2c4440f9a445b4498915e80a5c6e77dddb23fdd146da8b7ca56bfc16c35061b2e SHA512 8f339cbc1f190e3963766a6ac0ca938d4ef67eed0395b30630e233b5e6274ceb3f1ed28fd1fd0614440fe0d84e45a93f389ed8411531a1e98c15e796635bf768
+EBUILD recode-3.7.9.ebuild 1307 BLAKE2B fa1ea275681fa935a04ae1bc1f460aa8f1ea150663026dbcb22fd43e6b00d5ad8ce0e877d1a197761ff2c4632059b8627be0a7d9bf3a93830cb6fba4dfde274e SHA512 3ce036702e82736f1f8e1380228b033293c26cc084c00540e0a31b682a6778c91178d29d8b95aa46595f138cac552af4fc8d08d83a6d1c713bf16e0ddf6c25f6
MISC metadata.xml 431 BLAKE2B a2f1b90590a30ec6d561845193e29d2fde7254ece1cc31b777bc5d3ed85aae53a6abb23cd9a00f9fd07ac4e13ccabd35e2fc71816106e46c89ff0607e869419c SHA512 388038f9e95b0491e8061def1c405facb327e8feefeca08d7b425b143db03d4f7745c6b7515cc000f42992b97cc9e82aac7660e313a2159d324883792d6d85fb
diff --git a/app-text/recode/recode-3.7.11.ebuild b/app-text/recode/recode-3.7.11.ebuild
new file mode 100644
index 000000000000..84074fbac49b
--- /dev/null
+++ b/app-text/recode/recode-3.7.11.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Convert files between various character sets"
+HOMEPAGE="https://github.com/rrthomas/recode"
+SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+# librecode soname version
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/libiconv"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test ; then
+ has_version -b "dev-python/cython[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ tc-export CC LD
+
+ # on solaris -lintl is needed to compile
+ [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
+
+ # --without-included-gettext means we always use system headers
+ # and library
+ econf \
+ $(use_enable nls) \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-text/recode/recode-3.7.9.ebuild b/app-text/recode/recode-3.7.9.ebuild
index 824721b61d61..31a05a563f10 100644
--- a/app-text/recode/recode-3.7.9.ebuild
+++ b/app-text/recode/recode-3.7.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz
LICENSE="GPL-3+"
# librecode soname version
SLOT="0/3"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
IUSE="nls test"
RESTRICT="!test? ( test )"