summaryrefslogtreecommitdiff
path: root/app-text/recode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 18:11:38 +0000
commit6c0d1528e3598898fd1026a3da35ffede0a1f14a (patch)
treed5ab9d7f6d2b41d05fb156069ee81e9ed779f12b /app-text/recode
parent29efd7db303b443e103311cc0e458ee5c134e8e5 (diff)
gentoo auto-resync : 06:01:2023 - 18:11:38
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/Manifest2
-rw-r--r--app-text/recode/recode-3.7.13.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/app-text/recode/Manifest b/app-text/recode/Manifest
index f24584bb9bb8..79e6f9386d2f 100644
--- a/app-text/recode/Manifest
+++ b/app-text/recode/Manifest
@@ -1,3 +1,5 @@
DIST recode-3.7.12.tar.gz 2399126 BLAKE2B 420ba6f96d532da4ae0e1861b512c39ad59f1f63b0e0ef061dcff95c15ff4ed82a3b7bb72f6abb29f85588476a76cb5d50151ca9e3f857c2c1c09727ccdd2890 SHA512 365602bf7b20e5362d13d1ab5269419f7f0838fb81dc01c466ea99c38eb1b979f8d707d24ca3dabbd3a0c65cde97704b570007ac60689d88bbafd33351d37d95
+DIST recode-3.7.13.tar.gz 2400432 BLAKE2B 457ba7855aeb5ae8b0cc32ee82b5b61b1b46ba2908406c0c10a76ae242343f421e81038b9bb6784089e8e3e687ecc0f61a6263c24f6b234962f94853e9359734 SHA512 af86754ed2ed1dc414f1dd7ab3564d606abb309766fb02bf085e56241527a74ac7141617956d01b0797e8e426cfb39ec597bd221d8ad58d9246e96b228e65b00
EBUILD recode-3.7.12-r1.ebuild 1521 BLAKE2B 3445d43122f73fbc1a5c85e78f2433043f5b5f3627482ced67d733c016beeefd115ff5eca79b06ec3b659196557d8a64899449c2ea63a8fd0529c62924f12334 SHA512 1eb3427f0e2607c182dd165bc12e3688af8c9430584c0f66c8a67d8dca5f44d540a9cefb30622486de059c15c3093c1682b614991dbcaefcf8aee0994cbefccf
+EBUILD recode-3.7.13.ebuild 1529 BLAKE2B ec0b6da5377401d2f7410408946e583d12875c889eba167a9a2469237f4da025791fe3265781c1af84fb153ca5e81000ee857f31a09e7bcef6e00fecdbded822 SHA512 846bdf7a0edb7cb1e400e69257f980fdda86a92a09769efd121c56420510b570fc4fb00456ce539ad6c13e4d3bf04829f849a5b33209248ff51426c96754890d
MISC metadata.xml 431 BLAKE2B a2f1b90590a30ec6d561845193e29d2fde7254ece1cc31b777bc5d3ed85aae53a6abb23cd9a00f9fd07ac4e13ccabd35e2fc71816106e46c89ff0607e869419c SHA512 388038f9e95b0491e8061def1c405facb327e8feefeca08d7b425b143db03d4f7745c6b7515cc000f42992b97cc9e82aac7660e313a2159d324883792d6d85fb
diff --git a/app-text/recode/recode-3.7.13.ebuild b/app-text/recode/recode-3.7.13.ebuild
new file mode 100644
index 000000000000..b028f8eba188
--- /dev/null
+++ b/app-text/recode/recode-3.7.13.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit autotools flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Convert files between various character sets"
+HOMEPAGE="https://github.com/rrthomas/recode"
+SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+# librecode soname version
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/libiconv"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/cython[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC LD
+
+ # on solaris -lintl is needed to compile
+ [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
+
+ # -fanalyzer substantially slows down the build and isn't useful for
+ # us. It's useful for upstream as it's static analysis, but it's not
+ # useful when just getting something built.
+ export gl_cv_warn_c__fanalyzer=no
+
+ econf \
+ $(use_enable nls) \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}