summaryrefslogtreecommitdiff
path: root/app-text/qpdf/qpdf-10.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /app-text/qpdf/qpdf-10.6.3.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'app-text/qpdf/qpdf-10.6.3.ebuild')
-rw-r--r--app-text/qpdf/qpdf-10.6.3.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/app-text/qpdf/qpdf-10.6.3.ebuild b/app-text/qpdf/qpdf-10.6.3.ebuild
new file mode 100644
index 000000000000..a0421758bb94
--- /dev/null
+++ b/app-text/qpdf/qpdf-10.6.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/qpdf/${P}.tar.gz
+ doc? ( mirror://sourceforge/qpdf/${P}-doc.zip )
+"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# subslot = libqpdf soname version
+SLOT="0/28"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE="doc examples gnutls ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0=
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+BDEPEND="
+ dev-lang/perl
+ doc? ( app-arch/unzip )
+"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ # Keep an eye on https://qpdf.readthedocs.io/en/stable/packaging.html.
+ local myconf=(
+ --disable-check-autofiles
+
+ --disable-implicit-crypto
+ --enable-crypto-native
+
+ --disable-oss-fuzz
+ $(use_enable test test-compare-images)
+ )
+
+ if use ssl ; then
+ local crypto_provider=$(usex gnutls gnutls openssl)
+ myconf+=(
+ --with-default-crypto=${crypto_provider}
+ --enable-crypto-${crypto_provider}
+ )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ docompress -x /usr/share/doc/${PF}/singlehtml
+ dodoc -r "${WORKDIR}"/${P}-doc/.
+
+ fi
+
+ if use examples ; then
+ find examples/build/.libs -maxdepth 1 -type f -executable \
+ -exec dobin {} + || die
+ fi
+
+ # Completions
+ dobashcomp completions/bash/qpdf
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_qpdf
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}