summaryrefslogtreecommitdiff
path: root/app-text/q-text-as-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/q-text-as-data
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/q-text-as-data')
-rw-r--r--app-text/q-text-as-data/Manifest3
-rw-r--r--app-text/q-text-as-data/metadata.xml10
-rw-r--r--app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild41
3 files changed, 54 insertions, 0 deletions
diff --git a/app-text/q-text-as-data/Manifest b/app-text/q-text-as-data/Manifest
new file mode 100644
index 000000000000..86a4ef761ea6
--- /dev/null
+++ b/app-text/q-text-as-data/Manifest
@@ -0,0 +1,3 @@
+DIST q-1.5.0.tar.gz 58746 BLAKE2B a35f7ea605a42e81be1ee4899ed9e8c2b4e81e896b6e4c1eb6045b64cc7fa3ffdf6f754be168b3ebe25faa4c8b80f63e2ffff3174231357260263acf335b8d5c SHA512 d21dd16a31629e36f0dee72ebc574283c7937821cb2da7ccaacb8484a35b53193dad05fe9857d1498434a0c1083514ea5b9e5d8a636bcd51d4c5924cb7bb1b55
+EBUILD q-text-as-data-1.5.0.ebuild 989 BLAKE2B 75751694983c2558990cfb4e3cb595185f1093f81e173e60a39c6c6eee2ab5831d037ea31436afb52004d11d138b5ff190079e2170561e6271b5669d0f708095 SHA512 0061a746a1432124970ff40722fd756938f9e50b63ed916d21a814aea7beaece049df2c5ccb9308824972928f4c9ac5fdaf31497731acf9609c8d5453809a7f4
+MISC metadata.xml 300 BLAKE2B 57b125311f9ec6ca94d329e91209e85c77c3c739c2e2ca885dbe4a8c3d9a13627fcd4b64c79c9c672d30c0265eab241fb57114e0c23b46e01c60fb969d7d6f9c SHA512 3b90282d1ba8092665a1421e81e53a82dadcdf3c70ecdcc0c71e97e00d0ad2f7ba1e970d507ab9d354721cd13e08582ae21c482955372c5d8bc0caeb3d4505aa
diff --git a/app-text/q-text-as-data/metadata.xml b/app-text/q-text-as-data/metadata.xml
new file mode 100644
index 000000000000..5405551a7a2a
--- /dev/null
+++ b/app-text/q-text-as-data/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">harelba/q</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild b/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild
new file mode 100644
index 000000000000..3441091a9944
--- /dev/null
+++ b/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+# Does not yet support py3
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-r1
+
+DESCRIPTION="A CLI tool that allows direct execution of SQL-like queries on text"
+HOMEPAGE="http://harelba.github.io/q/"
+MY_P="q-${PV}"
+SRC_URI="https://github.com/harelba/q/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# No dependencies other than python >= 2.5
+# http://harelba.github.io/q/requirements.html
+RDEPEND="${PYTHON_DEPS}"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+q_install() {
+ python_newexe bin/q q-text-as-data
+}
+
+src_install() {
+ python_foreach_impl q_install
+ newdoc bin/.qrc dot-qrc
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ einfo "On Gentoo, the 'q' binary is most often provided by app-portage/portage-utils;"
+ einfo "Thus, this tool is install as 'q-text-as-data' rather than 'q'."
+}