summaryrefslogtreecommitdiff
path: root/app-text/q-text-as-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/q-text-as-data
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/q-text-as-data')
-rw-r--r--app-text/q-text-as-data/Manifest4
-rw-r--r--app-text/q-text-as-data/metadata.xml10
-rw-r--r--app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/app-text/q-text-as-data/Manifest b/app-text/q-text-as-data/Manifest
new file mode 100644
index 000000000000..a26546ffdcb0
--- /dev/null
+++ b/app-text/q-text-as-data/Manifest
@@ -0,0 +1,4 @@
+DIST q-1.5.0.tar.gz 58746 SHA256 69bde3fb75aa1d42ba306576b135b8a72121a995e6d865cc8c18db289c602c4b SHA512 d21dd16a31629e36f0dee72ebc574283c7937821cb2da7ccaacb8484a35b53193dad05fe9857d1498434a0c1083514ea5b9e5d8a636bcd51d4c5924cb7bb1b55 WHIRLPOOL 264ecbd3a064ba37fc581fea1f9c7b3e6a7f8985c6dcc1c6856193036e202ba3483b90502640f042a25b418eaecc881bc3246855812ffbf55126789b6e79a44f
+EBUILD q-text-as-data-1.5.0.ebuild 989 SHA256 a7ac78be3eb197ac267ede984a65541ef80157e025c38db83c8fe2cd922a5a40 SHA512 0061a746a1432124970ff40722fd756938f9e50b63ed916d21a814aea7beaece049df2c5ccb9308824972928f4c9ac5fdaf31497731acf9609c8d5453809a7f4 WHIRLPOOL 0d5c3a68ad0cab46f52e2eca42c8bd97a6de5f46794055471189e9d906f389b4a6c811333ef7225a724ceb8a7f8ccbe3421a4002c883cb5be5ffc58c276da32e
+MISC ChangeLog 571 SHA256 59469687f85b6f46bef17db0f89e32f0c1a03de370a0ec43b835885ce8c6a817 SHA512 46887a884f622118a9e239931863316396af80a6a6b269f3a886b66919991c84c29099b68348c9f6ba9de1c395f37630254bfbcec2a90a127d0ae532dc3e39d6 WHIRLPOOL 73421bd47f56e60ab7a3d1708e1a935c70fa9dfbda2e1bc57c96cbd7b2ce9581eacca52209f1eee98cc2949398395460f74f7a9ff3c61ed60b1ce7102832604e
+MISC metadata.xml 300 SHA256 4e1617413f888847bece031b7531b3426f761f836daeb53850fe3e828f09a0f6 SHA512 3b90282d1ba8092665a1421e81e53a82dadcdf3c70ecdcc0c71e97e00d0ad2f7ba1e970d507ab9d354721cd13e08582ae21c482955372c5d8bc0caeb3d4505aa WHIRLPOOL f1fdae1d3e02ac374762204dfd0c29fb8baaf446d54b2fa5a8982c874ebf2a9940bc94551cce1153423e2854253518de05caad3e1eacf7193b16d8d491c45259
diff --git a/app-text/q-text-as-data/metadata.xml b/app-text/q-text-as-data/metadata.xml
new file mode 100644
index 000000000000..5405551a7a2a
--- /dev/null
+++ b/app-text/q-text-as-data/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">harelba/q</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild b/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild
new file mode 100644
index 000000000000..3441091a9944
--- /dev/null
+++ b/app-text/q-text-as-data/q-text-as-data-1.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+# Does not yet support py3
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-r1
+
+DESCRIPTION="A CLI tool that allows direct execution of SQL-like queries on text"
+HOMEPAGE="http://harelba.github.io/q/"
+MY_P="q-${PV}"
+SRC_URI="https://github.com/harelba/q/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# No dependencies other than python >= 2.5
+# http://harelba.github.io/q/requirements.html
+RDEPEND="${PYTHON_DEPS}"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+q_install() {
+ python_newexe bin/q q-text-as-data
+}
+
+src_install() {
+ python_foreach_impl q_install
+ newdoc bin/.qrc dot-qrc
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ einfo "On Gentoo, the 'q' binary is most often provided by app-portage/portage-utils;"
+ einfo "Thus, this tool is install as 'q-text-as-data' rather than 'q'."
+}