summaryrefslogtreecommitdiff
path: root/app-text/pytextile/pytextile-3.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /app-text/pytextile/pytextile-3.0.3.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'app-text/pytextile/pytextile-3.0.3.ebuild')
-rw-r--r--app-text/pytextile/pytextile-3.0.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/pytextile/pytextile-3.0.3.ebuild b/app-text/pytextile/pytextile-3.0.3.ebuild
new file mode 100644
index 000000000000..ffe603741631
--- /dev/null
+++ b/app-text/pytextile/pytextile-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+MY_PN="python-textile"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Python port of Textile, A humane web text generator"
+HOMEPAGE="https://github.com/textile/python-textile"
+SRC_URI="https://github.com/textile/python-textile/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # remove useless --cov arg injection
+ rm pytest.ini || die
+ # remove useless pytest-runner dep
+ sed -e "s/pytest-runner//g" -i setup.py || die
+}
+
+python_test() {
+ pytest || die "Testsuite failed under ${EPYTHON}"
+}