summaryrefslogtreecommitdiff
path: root/app-text/pspresent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-21 01:03:25 +0000
commitd32022e7301aef2b3f52f6b7a3de81c6e03ffcaf (patch)
tree4e64fbab713348c061644255d893ff91f2d8b1e5 /app-text/pspresent
parent92f98ae772a60a2fa63efbda2f915da957a3b3b8 (diff)
gentoo auto-resync : 21:11:2022 - 01:03:25
Diffstat (limited to 'app-text/pspresent')
-rw-r--r--app-text/pspresent/Manifest3
-rw-r--r--app-text/pspresent/files/pspresent-1.3-makefile.patch39
-rw-r--r--app-text/pspresent/pspresent-1.3-r2.ebuild (renamed from app-text/pspresent/pspresent-1.3-r1.ebuild)34
3 files changed, 55 insertions, 21 deletions
diff --git a/app-text/pspresent/Manifest b/app-text/pspresent/Manifest
index da453a50ec8a..748350164a82 100644
--- a/app-text/pspresent/Manifest
+++ b/app-text/pspresent/Manifest
@@ -1,3 +1,4 @@
+AUX pspresent-1.3-makefile.patch 949 BLAKE2B be1514b651d32fd062129c2c42deb7dc1d9134e01ead14b0f4aef8838e65a0b0a37729ea277e9a2fbe95182ee8bfa40e4dc138bc69587810a03710ab1b1555d2 SHA512 9d6ff2a7b132a5888c1ce62ea5a3291c8c2f58ba849d34fefd5a53bcec84a65ac58528daefc25e963a8da1747ecde69a0ddd985e591e3fcf88e46b47d04761df
DIST pspresent-1.3.tar.gz 14357 BLAKE2B b15f288f2446ef0a9a00bcf454d9e55fc60a0547c534f0015695c6d2b23c5bd779acd2b423b01f6cd019cff419cdc79da8f8575804440c3f70bbeb29e5fa1b32 SHA512 cfca0b4758d03051cea95d077a45239103f6fd24dada775c3b7fb0b7f78863f6628b530a21834546546dc935596b6d93dbe45048a661fcc41152a4b97b8f21f3
-EBUILD pspresent-1.3-r1.ebuild 860 BLAKE2B e13256c827c441f64e42d289d03f52b629d9ef0e705cf6c2d9aa63375e9cf650664e033374e307d0a52ea2e9882ff1e9f5f2acde8965ffad1a28f9cb2d2229d1 SHA512 ecbd928c625cde9db7a01e79dc200994f323eddf7521b199091fabf19e9dcafc179da1616588181f57a14db2a3158113ea3a062f4b726ba42bc827c8c9a13773
+EBUILD pspresent-1.3-r2.ebuild 749 BLAKE2B 97f9a12b4ffda7dae0b3d74bcc0bdf8282543caeee8725b227194d7eb25656a4421da62ec24e299ea8d51e968e32efbbcc2c8210b144d441f55e23e36709e281 SHA512 ee891068a6fdad0f2c17c97f21d2816675cc00d7d82bca5173884d3b9c194cd00e453ab32d1a2c11eae1a4ed8841d1395a72bc335a03d8bde10a9ecb0de2b36c
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-text/pspresent/files/pspresent-1.3-makefile.patch b/app-text/pspresent/files/pspresent-1.3-makefile.patch
new file mode 100644
index 000000000000..363a52c57285
--- /dev/null
+++ b/app-text/pspresent/files/pspresent-1.3-makefile.patch
@@ -0,0 +1,39 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,28 +4,16 @@
+ #
+
+ # You may need to change these paths
+-X11_CFLAGS=-I/usr/X11R6/include
+-X11_LDLIBS=-L/usr/X11R6/lib -lX11
++X11_CFLAGS = $(shell $(PKG_CONFIG) --cflags x11)
++X11_LDLIBS = $(shell $(PKG_CONFIG) --libs x11)
+
+ # Remove the following two lines to disable XINERAMA support
+-XINERAMA_CFLAGS=-DHAVE_LIBXINERAMA
+-XINERAMA_LDLIBS=-lXext -lXinerama
++ifdef USE_XINERAMA
++XINERAMA_CFLAGS = -DHAVE_LIBXINERAMA $(shell $(PKG_CONFIG) --cflags xinerama)
++XINERAMA_LDLIBS = $(shell $(PKG_CONFIG) --libs xinerama)
++endif
+
+-CC = gcc
+-CFLAGS = -Wall -O2 $(X11_CFLAGS) $(XINERAMA_CFLAGS)
++CPPFLAGS += $(X11_CFLAGS) $(XINERAMA_CFLAGS)
+ LDLIBS = $(X11_LDLIBS) $(XINERAMA_LDLIBS)
+
+-TARGET = pspresent
+-OBJS = pspresent.o gs.o ps.o
+-
+-$(TARGET): $(OBJS)
+- $(CC) -o $(TARGET) $(OBJS) $(LDLIBS)
+-
+-clean:
+- rm $(TARGET) $(OBJS)
+-
+-.SUFFIXES:
+-.SUFFIXES: .c .o
+-
+-.c.o:
+- $(CC) $(CFLAGS) -o $@ -c $<
++pspresent: gs.o ps.o
diff --git a/app-text/pspresent/pspresent-1.3-r1.ebuild b/app-text/pspresent/pspresent-1.3-r2.ebuild
index 24ed68ea8e0b..167d8e647c8a 100644
--- a/app-text/pspresent/pspresent-1.3-r1.ebuild
+++ b/app-text/pspresent/pspresent-1.3-r2.ebuild
@@ -1,38 +1,32 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="A tool to display full-screen PostScript presentations"
-SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
HOMEPAGE="http://www.cse.unsw.edu.au/~matthewc/pspresent/"
-SLOT="0"
-LICENSE="GPL-2"
+SRC_URI="http://www.cse.unsw.edu.au/~matthewc/pspresent/${P}.tar.gz"
-IUSE="xinerama"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc x86"
+IUSE="xinerama"
-RDEPEND="x11-libs/libX11
- xinerama? ( x11-libs/libXinerama )
- app-text/ghostscript-gpl"
+RDEPEND="
+ app-text/ghostscript-gpl
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
-src_prepare() {
- default
- if ! use xinerama ; then
- sed -i -e "/^XINERAMA/s/^/#/g" Makefile || die "sed Makefile"
- fi
- sed -i Makefile \
- -e 's|= -Wall -O2|+= -Wall|g' \
- -e 's| -o | $(LDFLAGS)&|g' \
- || die "sed Makefile"
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-src_compile() {
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC PKG_CONFIG
+ use xinerama && export USE_XINERAMA=1
}
src_install() {