summaryrefslogtreecommitdiff
path: root/app-text/pspdftool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/pspdftool
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/pspdftool')
-rw-r--r--app-text/pspdftool/Manifest4
-rw-r--r--app-text/pspdftool/metadata.xml10
-rw-r--r--app-text/pspdftool/pspdftool-0.03.ebuild39
-rw-r--r--app-text/pspdftool/pspdftool-9999.ebuild37
4 files changed, 90 insertions, 0 deletions
diff --git a/app-text/pspdftool/Manifest b/app-text/pspdftool/Manifest
new file mode 100644
index 000000000000..2e9763625b46
--- /dev/null
+++ b/app-text/pspdftool/Manifest
@@ -0,0 +1,4 @@
+DIST pspdftool-0.03.tar.bz2 129936 BLAKE2B 100ae29a9d929475d90c0acd6c5e50b61c65d690489ef223238bd19f567757635e0b0e774ff4561aa8e41476dd9a270ef8abafb307ad354e4f919b5ce578cf9c SHA512 8e621719c59f79f7201e8221a851e85d11573fa1895a64ab5e77382fa1103004f70a38f98928a8ce4b5795ce89ac3e4a7a5eade772959e26e49d6db9cc7fe7ea
+EBUILD pspdftool-0.03.ebuild 882 BLAKE2B 0e0793ed9090b7a2218ef8bdd9d1fc50aec0a8b062eb608e2a2742c81f967129d060bbb1eb4972ef64f894c8525c1204480e03a6bd56c3626382ecaadc8a4e92 SHA512 2555568da3e8feb2a0bf29384b67f5204eeb61dcf176d976f2c5f66718a1ab9c0f377d3ad0a89169fe8fb7cfec13864a02fb48a275e9a50299932f87dc52e28c
+EBUILD pspdftool-9999.ebuild 806 BLAKE2B 83accfdbff4beacbbebbf52f22749868028d38b75641dc3171059b025c35ad0ce3bfb613cf90b4dacbe38a5464e1980acfe712cdbb7eb76d2333e27a3892f9b2 SHA512 a0a04775997d3cd9cd460ceb49f96d34cd225590a6d9f39ad65a80d0c04212e31641d621ffffad3742bba70bc1bddabe9e9adbdabaec2ac45ef90718481e227a
+MISC metadata.xml 472 BLAKE2B 4d992ab0dcf156856d6db38578317e7ea01a23d092cbf67bf14095c52c7db59399ad652f868e4ae941ecb389d8ff78e43f0408e7929c56f36aa62f4cbae471a8 SHA512 1e2c1073495d42708c1f46a3698a55e3de6362fc1ed3ab2a5c76050733b14b0bb4cbedfbc8e12b4f283896587dae1f9c818f52e56a560e5c91a39a362ddbe813
diff --git a/app-text/pspdftool/metadata.xml b/app-text/pspdftool/metadata.xml
new file mode 100644
index 000000000000..fadc3f11108f
--- /dev/null
+++ b/app-text/pspdftool/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+Pspdftool is a tool for preprinting preparation of documents. It supports PostScript and PDF files and allows users do several transformations (for example rotation, scale, miror ...) and pages selections.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pspdftool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pspdftool/pspdftool-0.03.ebuild b/app-text/pspdftool/pspdftool-0.03.ebuild
new file mode 100644
index 000000000000..5b6cbb7e2ecf
--- /dev/null
+++ b/app-text/pspdftool/pspdftool-0.03.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+ESVN_REPO_URI="https://svn.code.sf.net/p/pspdftool/code/trunk"
+ESVN_PROJECT="pspdftool"
+
+[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
+inherit autotools ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
+HOMEPAGE="https://sourceforge.net/projects/pspdftool"
+[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ "${PV}" == "9999" ]] || \
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib ) "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with zlib)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}*
+}
diff --git a/app-text/pspdftool/pspdftool-9999.ebuild b/app-text/pspdftool/pspdftool-9999.ebuild
new file mode 100644
index 000000000000..96932275aac6
--- /dev/null
+++ b/app-text/pspdftool/pspdftool-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+ESVN_REPO_URI="https://svn.code.sf.net/p/pspdftool/code/trunk"
+ESVN_PROJECT="pspdftool"
+
+[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
+inherit autotools ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
+HOMEPAGE="https://sourceforge.net/projects/pspdftool"
+[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+[[ "${PV}" == "9999" ]] || \
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib ) "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with zlib)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}*
+}