summaryrefslogtreecommitdiff
path: root/app-text/psiconv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-text/psiconv
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-text/psiconv')
-rw-r--r--app-text/psiconv/Manifest4
-rw-r--r--app-text/psiconv/files/psiconv-0.8.3-Wimplicit-function-declaration.patch92
-rw-r--r--app-text/psiconv/files/psiconv-0.8.3-gcc10-fno-common.patch21
-rw-r--r--app-text/psiconv/psiconv-0.8.3-r1.ebuild21
4 files changed, 128 insertions, 10 deletions
diff --git a/app-text/psiconv/Manifest b/app-text/psiconv/Manifest
index dc6d3a193f5f..44b0e9ca320d 100644
--- a/app-text/psiconv/Manifest
+++ b/app-text/psiconv/Manifest
@@ -1,3 +1,5 @@
+AUX psiconv-0.8.3-Wimplicit-function-declaration.patch 1753 BLAKE2B 94c3effba9da16e3baa58d09e7f93be3a1658c6b77a31aaff13f60e9c752823cb2deaa32836f208c597f2948fb66c89e2c9e4c15b286863106c38a101dffaef5 SHA512 ed9c06ba1e53b2ba84e5fb585976398514599eec8974b071e5d44f395cc059477e59dd33230ded7fb4255bd6f6052e643a74a13ba68e075c0d7f8c6ceefdd0f1
+AUX psiconv-0.8.3-gcc10-fno-common.patch 563 BLAKE2B cf6ff5a05283739bcaf8fbc4177927c6d396af4fa517a838727b668f4b2118d433022d1f66e2e4f25b01f576cbfe54555bf74482c48a184a86242cdf058b349b SHA512 25133db789feb733a358847c1f5be7d13995dfc81533a9761df6d2eb18c2c4b6af86e13003b4f0c35dcd3313220ce7a559bc0bf869d89bdedfce13a29890dae9
DIST psiconv-0.8.3.tar.gz 326460 BLAKE2B add1a863c706dfe00ddace65e7083924cd37766a7e17339d1626c6a65ba00bb72e6687a6e1409febf81efd5fb1f7937b60f83e8afcca67f3a47c40611118c82c SHA512 a48814f64fd2c3dda0dfa13c331d2d60ff8674ab7a56f51efcad29d3dd6874f4b94dc0a21ef3066b0fa605b18635ee151fbb4e3eeb06dab3854a329ed70348a9
-EBUILD psiconv-0.8.3-r1.ebuild 579 BLAKE2B 3975ca13de7d3483b84bda156d4af4e882d9e9027331ac2f5efc375ae5922b40809ce0e54077aae030d21ad9dedfa50201fb94265c5fad5fabea041eb1369d14 SHA512 9a03f74797245f144f8a1b81c463bca6a151132c349699bd95527524190eaaa0256fa8b105bec8914d0c2fb80cee8e2652b0c8971447678e78133f0f4a141b92
+EBUILD psiconv-0.8.3-r1.ebuild 645 BLAKE2B 8045280a6048cc3686598e0667125c163f41d3d4abbaf7c0a31dc4fef797105eedb669f4926e21e7ac565bced84f0ee2af2da153e9a0d76616ce3771602c7b19 SHA512 d6ff83339ea40e0126f3b11a5f8fc0b990232ed20140402ea87befb2ce12661a4d7b5524079e22289d1338a630726ec8671ffd3349ed33c3583e13f3942dbf05
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/psiconv/files/psiconv-0.8.3-Wimplicit-function-declaration.patch b/app-text/psiconv/files/psiconv-0.8.3-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..9d01c2d87de3
--- /dev/null
+++ b/app-text/psiconv/files/psiconv-0.8.3-Wimplicit-function-declaration.patch
@@ -0,0 +1,92 @@
+--- a/extra/checkuid.c
++++ b/extra/checkuid.c
+@@ -19,6 +19,7 @@
+
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ unsigned long uid1[32] = { /* bit 0 */ 0x000045A0,
+ /* bit 1 */ 0x00008B40,
+--- a/extra/empty.c
++++ b/extra/empty.c
+@@ -20,6 +20,7 @@
+ #include <psiconv/generate.h>
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ void help(void)
+ {
+--- a/extra/rewrite.c
++++ b/extra/rewrite.c
+@@ -21,6 +21,7 @@
+ #include <psiconv/generate.h>
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ int main(int argc, char *argv[])
+ {
+--- a/lib/psiconv/error.c
++++ b/lib/psiconv/error.c
+@@ -22,6 +22,7 @@
+ #include <stdarg.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "error.h"
+
+--- a/lib/psiconv/generate_layout.c
++++ b/lib/psiconv/generate_layout.c
+@@ -23,6 +23,8 @@
+ #include "generate_routines.h"
+ #include "error.h"
+
++#include <string.h>
++
+ #ifdef DMALLOC
+ #include <dmalloc.h>
+ #endif
+--- a/lib/psiconv/generate_simple.c
++++ b/lib/psiconv/generate_simple.c
+@@ -23,6 +23,8 @@
+ #include "generate_routines.h"
+ #include "error.h"
+
++#include <string.h>
++
+ #ifdef DMALLOC
+ #include <dmalloc.h>
+ #endif
+--- a/lib/psiconv/list.c
++++ b/lib/psiconv/list.c
+@@ -23,6 +23,7 @@
+ #include <stddef.h>
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include "general.h"
+ #include "list.h"
+ #include "error.h"
+--- a/lib/psiconv/misc.c
++++ b/lib/psiconv/misc.c
+@@ -22,6 +22,7 @@
+ #include <stdarg.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "common.h"
+
+ #ifdef DMALLOC
+--- a/lib/psiconv/parse_driver.c
++++ b/lib/psiconv/parse_driver.c
+@@ -21,6 +21,7 @@
+ #include "compat.h"
+
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "parse.h"
+ #include "parse_routines.h"
diff --git a/app-text/psiconv/files/psiconv-0.8.3-gcc10-fno-common.patch b/app-text/psiconv/files/psiconv-0.8.3-gcc10-fno-common.patch
new file mode 100644
index 000000000000..4c21a6ed3d4a
--- /dev/null
+++ b/app-text/psiconv/files/psiconv-0.8.3-gcc10-fno-common.patch
@@ -0,0 +1,21 @@
+--- a/program/psiconv/psiconv.c
++++ b/program/psiconv/psiconv.c
+@@ -41,6 +41,8 @@
+ #include "gen.h"
+ #include "psiconv.h"
+
++psiconv_list fileformat_list;
++
+ static void print_help(void);
+ static void print_version(void);
+ static void strtoupper(char *str);
+--- a/program/psiconv/psiconv.h
++++ b/program/psiconv/psiconv.h
+@@ -31,6 +31,6 @@
+ output_function *output;
+ } *psiconv_fileformat;
+
+-psiconv_list fileformat_list; /* of struct psiconv_fileformat */
++extern psiconv_list fileformat_list; /* of struct psiconv_fileformat */
+
+ #endif /* PSICONV_GEN_H */
diff --git a/app-text/psiconv/psiconv-0.8.3-r1.ebuild b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
index 004004aee641..84ee5132d4f5 100644
--- a/app-text/psiconv/psiconv-0.8.3-r1.ebuild
+++ b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -9,20 +9,23 @@ DESCRIPTION="An interpreter for Psion 5(MX) file formats"
HOMEPAGE="http://huizen.dds.nl/~frodol/psiconv"
SRC_URI="http://huizen.dds.nl/~frodol/${PN}/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-IUSE="static-libs"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
-src_prepare() {
- tc-export AR
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc10-fno-common.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
src_configure() {
- econf $(use_enable static-libs static)
+ tc-export AR
+ econf --disable-static
}
src_install() {
default
- use static-libs || rm -fr "${D}"usr/lib*/lib${PN}.la
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}