summaryrefslogtreecommitdiff
path: root/app-text/psiconv/psiconv-0.8.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/psiconv/psiconv-0.8.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/psiconv/psiconv-0.8.3-r1.ebuild')
-rw-r--r--app-text/psiconv/psiconv-0.8.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/psiconv/psiconv-0.8.3-r1.ebuild b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..004004aee641
--- /dev/null
+++ b/app-text/psiconv/psiconv-0.8.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="An interpreter for Psion 5(MX) file formats"
+HOMEPAGE="http://huizen.dds.nl/~frodol/psiconv"
+SRC_URI="http://huizen.dds.nl/~frodol/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="static-libs"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+src_prepare() {
+ tc-export AR
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -fr "${D}"usr/lib*/lib${PN}.la
+}