summaryrefslogtreecommitdiff
path: root/app-text/ps2eps/ps2eps-1.68.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/ps2eps/ps2eps-1.68.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/ps2eps/ps2eps-1.68.ebuild')
-rw-r--r--app-text/ps2eps/ps2eps-1.68.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/ps2eps/ps2eps-1.68.ebuild b/app-text/ps2eps/ps2eps-1.68.ebuild
new file mode 100644
index 000000000000..407dde790949
--- /dev/null
+++ b/app-text/ps2eps/ps2eps-1.68.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generate Encapsulated Postscript Format files from one-page Postscript documents"
+HOMEPAGE="http://www.tm.uka.de/~bless/ps2eps"
+SRC_URI="http://www.tm.uka.de/~bless/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-text/ghostscript-gpl
+ !<app-text/texlive-core-2007-r7"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ tc-export CC
+ cd "${S}/src/C"
+ echo "all: bbox" > Makefile
+ emake || die "making bbox failed"
+}
+
+src_install() {
+ dobin "${S}/src/C/bbox"
+ dobin "${S}/bin/ps2eps"
+ doman "${S}/doc/man/man1/bbox.1"
+ doman "${S}/doc/man/man1/ps2eps.1"
+
+ dodoc Changes.txt README.txt
+ dohtml "${S}/doc/html/"*
+ docinto pdf
+ dodoc "${S}/doc/pdf/"*
+}