summaryrefslogtreecommitdiff
path: root/app-text/poppler-data/poppler-data-0.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /app-text/poppler-data/poppler-data-0.4.9.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'app-text/poppler-data/poppler-data-0.4.9.ebuild')
-rw-r--r--app-text/poppler-data/poppler-data-0.4.9.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-text/poppler-data/poppler-data-0.4.9.ebuild b/app-text/poppler-data/poppler-data-0.4.9.ebuild
new file mode 100644
index 000000000000..ecc3bd95ac2f
--- /dev/null
+++ b/app-text/poppler-data/poppler-data-0.4.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Data files for poppler to support uncommon encodings without xpdfrc"
+HOMEPAGE="https://poppler.freedesktop.org/"
+SRC_URI="https://poppler.freedesktop.org/${P}.tar.gz"
+
+LICENSE="BSD GPL-2 MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+src_install() {
+ emake prefix="${EPREFIX}"/usr DESTDIR="${D}" install
+
+ # bug 409361
+ dodir /usr/share/poppler/cMaps
+ cd "${D}/${EPREFIX}"/usr/share/poppler/cMaps || die
+ find ../cMap -type f -exec ln -s {} . \; || die
+}