summaryrefslogtreecommitdiff
path: root/app-text/pep/pep-2.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/pep/pep-2.8-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/pep/pep-2.8-r1.ebuild')
-rw-r--r--app-text/pep/pep-2.8-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/pep/pep-2.8-r1.ebuild b/app-text/pep/pep-2.8-r1.ebuild
new file mode 100644
index 000000000000..59b13dc23d46
--- /dev/null
+++ b/app-text/pep/pep-2.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="General purpose filter and file cleaning program"
+HOMEPAGE="http://hannemyr.com/enjoy/pep.html"
+SRC_URI="http://hannemyr.com/enjoy/${PN}${PV//./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ppc x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ # pep does not come with autconf so here's a patch to configure
+ # Makefile with the correct path
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-include.patch
+ # Darwin lacks stricmp and DIRCHAR
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e '/^OBJS/s/^\(.*\)$/\1 bdmg.o/' Makefile
+ append-flags "-Dunix" -DSTRICMP
+ fi
+}
+
+src_compile() {
+ # make man page too
+ make Doc/pep.1 || die "make man page failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin pep || die "dobin failed"
+ doman Doc/pep.1 || die "doman failed"
+
+ insinto /usr/share/pep
+ doins Filters/* || die "doins failed"
+
+ dodoc aareadme.txt file_id.diz
+}