summaryrefslogtreecommitdiff
path: root/app-text/pelican
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-12 13:33:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-12 13:33:15 +0100
commite4b9f141e31db1e069e3bcf5b1fb81af77b0cace (patch)
treed1879c44ce14e7b9450b0f9c711f653779584754 /app-text/pelican
parentbd3c6f11646b7601637fa3245cf8a363e9fa0034 (diff)
gentoo auto-resync : 12:07:2022 - 13:33:15
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/Manifest3
-rw-r--r--app-text/pelican/pelican-4.8.0.ebuild (renamed from app-text/pelican/pelican-9999.ebuild)42
2 files changed, 32 insertions, 13 deletions
diff --git a/app-text/pelican/Manifest b/app-text/pelican/Manifest
index 53d64a18cbd7..d78c8929c4db 100644
--- a/app-text/pelican/Manifest
+++ b/app-text/pelican/Manifest
@@ -1,4 +1,5 @@
DIST pelican-4.7.2.tar.gz 1401737 BLAKE2B c277844c0c153f71aae051dd8897e9abf8fd1ddc7c49251aaa7b85b7324a85da0ded74e8328a4b64ec79b8e6b4e143d5496b8535900c8a88bfa6198489c0a80c SHA512 9fbf2ecb3c193e976e01a4d095095ac55d56fe45aa24467d91635bbecb9df933ccabd6a456e14c6ee14ce0a845820be8d887917af314e13c7a3eb830cb0ce7e6
+DIST pelican-4.8.0.gh.tar.gz 1401791 BLAKE2B 889c9054659c9f98cca571fa0f3ea9ee7752aa65c3feb71278570bad74095f521d3838aa1a32dc3ae331ba86149cdd10be9c31c7ed5bc6e06348edf3eb3bb081 SHA512 2e94eb88a836bcb430026463c0e7e906b7f065507e0d873b6e0fc980e271e6a8f2e62b22af4b61c963d90ef61d57787de20656fe7497b0ae14e93eff2d364f3b
EBUILD pelican-4.7.2-r1.ebuild 1490 BLAKE2B 7764a1122ac5fa2e3bb5e20e3b1041da6ced02c8f50f66c621f5bc86a79766a1f7150c0491dbc9d48ad87094ef584ff3f38599c6a257047fd27564f34a4e7c0a SHA512 e5877f67e351166c057d8027f1c9c121d6b50e6c497d2adecc702d65292a0258eed17255bd84755d6fdd3aba81fe78b41f82af681bcd32aa10f06401ee7a6d1c
-EBUILD pelican-9999.ebuild 1479 BLAKE2B e59c32738a088a5cff6f2d94c6b5c7d3d65533e30f6207e4ca6c2d1f2bb32ec9ac9b8b3cfb9e7241f35de6cb992fe0e0f7f249ea3925219ac437d204440f6204 SHA512 d42118d548e2f7f8dd73bbceb2af56062cf48adb26321e276652cee657812a3e7764b126b5f0a785ea6a508f94341d603bfacd7553ab78bcc05010e4854b074b
+EBUILD pelican-4.8.0.ebuild 2025 BLAKE2B 3df393cc88bf8ecf7931dc29f7820585d88dbdfed326fbc77b4e45d57f5d242d7887ef94fe8ad049b9f2e66e8c9e48d68169aa22f1af65cc7e5e3c3362770767 SHA512 729afc740745b082cba1f7f04319d8b384c3b378fb99830cbd952a39c5acabef4ac9d6cc1a7a4998f5cb6c5cd836408039d7e813312d4b4363d1751bcfbafa85
MISC metadata.xml 463 BLAKE2B 2f062e4ee585182b37fdd094c75fe58aa600c57a416c955da7abef66e0c42eb1cd1d1d2b38c3cb322a6e0f044ffabf3915aedd16dee147f6a94fb92205f0d196 SHA512 5bc95a863d0741b536c3b9d3c2f7f9181ec5a26be18f15a1df4f691c8cafa0498d6ed57db37563ea972f8ea025f92c8f92729d97967b044f885989b996646d12
diff --git a/app-text/pelican/pelican-9999.ebuild b/app-text/pelican/pelican-4.8.0.ebuild
index aa9807867aa1..ea0e121101a7 100644
--- a/app-text/pelican/pelican-9999.ebuild
+++ b/app-text/pelican/pelican-4.8.0.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 optfeature
DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
-EGIT_REPO_URI="https://github.com/getpelican/pelican.git"
-EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
IUSE="doc examples markdown"
-RESTRICT="test"
RDEPEND=">=dev-python/docutils-0.16[${PYTHON_USEDEP}]
>=dev-python/blinker-1.4[${PYTHON_USEDEP}]
>=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
@@ -29,11 +28,24 @@ RDEPEND=">=dev-python/docutils-0.16[${PYTHON_USEDEP}]
>=dev-python/unidecode-1.1[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
markdown? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
-BDEPEND="test? ( >=dev-python/markdown-3.1[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ >=dev-python/markdown-3.1[${PYTHON_USEDEP}]
+ dev-python/typogrify[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
DOCS=( README.rst )
-distutils_enable_tests nose
+EPYTEST_DESELECT=(
+ # Needs investigation, we weren't running tests at all before
+ pelican/tests/test_testsuite.py::TestSuiteTest::test_error_on_warning
+ pelican/tests/test_pelican.py::TestPelican::test_basic_generation_works
+ pelican/tests/test_pelican.py::TestPelican::test_custom_generation_works
+)
+
+distutils_enable_tests pytest
python_compile_all() {
use doc && emake -C docs html
@@ -41,10 +53,16 @@ python_compile_all() {
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
+
if use examples; then
- insinto "/usr/share/doc/${PF}"
- docompress -x "/usr/share/doc/${PF}/samples"
- doins -r samples
+ docinto /usr/share/doc/${PF}
+ docompress -x /usr/share/doc/${PF}/samples
+ dodoc -r samples
fi
+
distutils-r1_python_install_all
}
+
+pkg_postinst() {
+ optfeature "Typographical enhancements (alternative to markdown)" dev-python/typogrify
+}