summaryrefslogtreecommitdiff
path: root/app-text/pdftk/pdftk-2.02.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /app-text/pdftk/pdftk-2.02.ebuild
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'app-text/pdftk/pdftk-2.02.ebuild')
-rw-r--r--app-text/pdftk/pdftk-2.02.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-text/pdftk/pdftk-2.02.ebuild b/app-text/pdftk/pdftk-2.02.ebuild
index 0aa09e4f2ac2..d026f23fdf69 100644
--- a/app-text/pdftk/pdftk-2.02.ebuild
+++ b/app-text/pdftk/pdftk-2.02.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -13,8 +13,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux"
-DEPEND="sys-devel/gcc[gcj]"
-RDEPEND="${DEPEND}"
+RDEPEND="sys-devel/gcc:5.4.0[gcj]"
+DEPEND="${RDEPEND}
+ sys-devel/gcc-config
+"
S="${WORKDIR}/${P}-dist/${PN}"
@@ -27,6 +29,9 @@ src_compile() {
unset CLASSPATH
unset JAVA_HOME
+ # We need gcc-5 because of Java
+ export PATH="$(gcc-config -B 5.4.0):${PATH}"
+
# Parallel make fails; confirmed, still not fixed in version 2.02.
emake -j1 -f "${S}"/Makefile.Debian || die "Compilation failed."
}