summaryrefslogtreecommitdiff
path: root/app-text/pdfsandwich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/pdfsandwich
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/pdfsandwich')
-rw-r--r--app-text/pdfsandwich/Manifest3
-rw-r--r--app-text/pdfsandwich/metadata.xml23
-rw-r--r--app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild37
3 files changed, 63 insertions, 0 deletions
diff --git a/app-text/pdfsandwich/Manifest b/app-text/pdfsandwich/Manifest
new file mode 100644
index 000000000000..d49131d2bca4
--- /dev/null
+++ b/app-text/pdfsandwich/Manifest
@@ -0,0 +1,3 @@
+DIST pdfsandwich-0.1.4.tar.bz2 16401 BLAKE2B cb431f35b199e3e6290c60a3f6c7b2621dd3652a29346092869d8e5f86f5664079de1ef431f9b5e8b9f7cc044d64006295a8176d6a28b2ea5fb820db8c952000 SHA512 ee03aea13c72cc5a02136b5d16d2425f685f0b7a9d6fa6cff6c792bd24e6316720dff321b5e8237b949c98c713f39cb8b08b855b76e2a77350927b1ee7943171
+EBUILD pdfsandwich-0.1.4-r1.ebuild 970 BLAKE2B 416b43bc2a95175aabde4379e23207fa524bb882e4b40c7c61c1fff87fb6b016721bff23720b2bf7712892b4eb7d5786edf7c5500dadb9a5ec1646eb7612c8b7 SHA512 3505739fec5f3d76a7d51c0c9f4f4cf992faa59e23779dfd0ebf677246da0a794ca18af304a5631e7fc0984bd698bfe69f6c3a012389cdc943a543ac0fe4b263
+MISC metadata.xml 937 BLAKE2B 7e13ea95d5add452b52f7223411d798148e6bac03aa636237ad3e5c0677d0bdedf4a5f5a2c63caf0e84ab92626e0f8de5b1dc3df0f5d8747163d626dbe632f00 SHA512 595e3fdd841667046ae3064ee12aa288586cb1db3f8cd902aaf5c7c1bfb1c1776c641c400593b273dad83bf4f3a4c98f1f031125b8d65af3e836d6c2abdbc531
diff --git a/app-text/pdfsandwich/metadata.xml b/app-text/pdfsandwich/metadata.xml
new file mode 100644
index 000000000000..0fb15c19e847
--- /dev/null
+++ b/app-text/pdfsandwich/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+pdfsandwich generates "sandwich" OCR pdf files, i.e. pdf files which
+contain only images (no text) will be processed by optical character
+recognition (OCR) and the text will be added to each page invisibly
+"behind" the images.
+
+pdfsandwich is a command line tool which is supposed to be useful to
+OCR scanned books or journals. It is able to recognize the page layout
+even for multicolumn text.
+
+Essentially, pdfsandwich is a wrapper script which calls the following
+binaries: convert, cuneiform, gs, and hocr2pdf. It is known to run on
+Unix systems and has been tested on Linux and MacOS X. It supports
+parallel processing on multiprocessor systems.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pdfsandwich</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild b/app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..21bf32dcc96f
--- /dev/null
+++ b/app-text/pdfsandwich/pdfsandwich-0.1.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="generator of sandwich OCR pdf files"
+HOMEPAGE="http://www.tobias-elze.de/pdfsandwich"
+SRC_URI="mirror://sourceforge/pdfsandwich/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="png"
+
+RDEPEND=">=app-text/tesseract-3.00
+ media-gfx/exact-image
+ app-text/unpaper
+ app-text/ghostscript-gpl
+ virtual/imagemagick-tools[png?]"
+DEPEND="sys-apps/gawk
+ >=dev-lang/ocaml-3.10[ocamlopt]"
+
+src_prepare() {
+ sed -i "/^OCAMLOPTFLAGS/s/$/ -ccopt \"\$(CFLAGS) \$(LDFLAGS)\"/" Makefile || die
+ sed -i "s/install -s/install/" Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ elog "pdfsandwich relies on the tesseract library for OCR."
+ elog "Consequently language support is determined by tesseract's"
+ elog "language support which in turn is controlled via the LINGUAS"
+ elog "variable in make.conf."
+}