summaryrefslogtreecommitdiff
path: root/app-text/pdfarranger/pdfarranger-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-text/pdfarranger/pdfarranger-1.3.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-text/pdfarranger/pdfarranger-1.3.1.ebuild')
-rw-r--r--app-text/pdfarranger/pdfarranger-1.3.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-text/pdfarranger/pdfarranger-1.3.1.ebuild b/app-text/pdfarranger/pdfarranger-1.3.1.ebuild
new file mode 100644
index 000000000000..c0ea69749fb1
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages."
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP},cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ app-text/poppler[introspection]"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]"