summaryrefslogtreecommitdiff
path: root/app-text/pdf2html/pdf2html-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /app-text/pdf2html/pdf2html-1.4.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'app-text/pdf2html/pdf2html-1.4.ebuild')
-rw-r--r--app-text/pdf2html/pdf2html-1.4.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-text/pdf2html/pdf2html-1.4.ebuild b/app-text/pdf2html/pdf2html-1.4.ebuild
index 745c02563434..3dfc5cf35421 100644
--- a/app-text/pdf2html/pdf2html-1.4.ebuild
+++ b/app-text/pdf2html/pdf2html-1.4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Converts pdf files to html files"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/pdf2html/"
@@ -19,22 +20,21 @@ RDEPEND="${DEPEND}
app-text/ghostscript-gpl
>=media-gfx/imagemagick-6"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-libpng15.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-libpng15.patch
+)
src_compile() {
tc-export CC
# Rewrite the Makefile as that's simpler
- echo "LDLIBS=-lpng" > Makefile
- echo "all: pbm2png" >> Makefile
+ echo "LDLIBS=-lpng" > Makefile || die "echo failed"
+ echo "all: pbm2png" >> Makefile || die "echo #2 failed"
emake
- echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile
+ echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile || die "echo #3 failed"
emake pbm2eps9
- echo "cp \"${EPREFIX}\"/usr/share/${P}/*.png ." >> pdf2html
+ echo "cp \"${EPREFIX}\"/usr/share/${P}/*.png ." >> pdf2html || die "echo #4 failed"
}
src_install() {