summaryrefslogtreecommitdiff
path: root/app-text/pastebinit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/pastebinit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/pastebinit')
-rw-r--r--app-text/pastebinit/Manifest3
-rw-r--r--app-text/pastebinit/metadata.xml10
-rw-r--r--app-text/pastebinit/pastebinit-1.5.ebuild57
3 files changed, 70 insertions, 0 deletions
diff --git a/app-text/pastebinit/Manifest b/app-text/pastebinit/Manifest
new file mode 100644
index 000000000000..d03c5e64a64c
--- /dev/null
+++ b/app-text/pastebinit/Manifest
@@ -0,0 +1,3 @@
+DIST pastebinit-1.5.tar.bz2 42941 BLAKE2B 678df7f2e77cc832fc9e152fb451538284033d181d9165b1a1194b254ad08ca1ac3e4612dddf7db6c62c1c3c59265ad94a78cc6df9457565264864ab06bff00b SHA512 cc4b7c46ab7932be3a1064ce7a1d91da3ebf4b132ad44b0090c8d431bfc68e945357344e59ac1239e37b3178de124930c5c8dc552b42f16c39c0452ac9ab8099
+EBUILD pastebinit-1.5.ebuild 1340 BLAKE2B f179103c378e9ce18a2d015864780200f4822fd890d4f0b260089932f2a6a99061b07a2c58385fa0017d452bae2996d74c4fc0fa09dd7f62743922e82d22c862 SHA512 7f2cab15367a685f65881271f6860d5569d6d021fe18d66f190dbb9005bd0fb288fa68932586052443ab5457121b7759040d1ee390d52b7616e828c0bdd673e5
+MISC metadata.xml 300 BLAKE2B 57c8bc28049b8b085b6e522604afabd2b2c8d35fd60bbdafff35b0c4a577c283c8b5491e44f8bea37cbf7b0431b57b058cbbba840caf7b665b5e865b192df6d0 SHA512 7dc26c0febbda314bdcba49514f0222c0cca81d0fc20a0576061b406c1ba388a0d190888b98f61291b4b3e251115c0417ea6a6e2aebae1d32678d182741fb39f
diff --git a/app-text/pastebinit/metadata.xml b/app-text/pastebinit/metadata.xml
new file mode 100644
index 000000000000..eaf351ef1efe
--- /dev/null
+++ b/app-text/pastebinit/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="crypt">Install pbputs for gpg-encrypted pastes</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">pastebinit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pastebinit/pastebinit-1.5.ebuild b/app-text/pastebinit/pastebinit-1.5.ebuild
new file mode 100644
index 000000000000..9e79db0da019
--- /dev/null
+++ b/app-text/pastebinit/pastebinit-1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="A software that lets you send anything you want directly to a pastebin"
+HOMEPAGE="https://launchpad.net/pastebinit"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="crypt"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ crypt? ( app-crypt/gnupg )"
+DEPEND="app-text/docbook-xsl-stylesheets"
+
+src_prepare() {
+ local mo=""
+
+ for lang in ${LINGUAS}; do
+ if [ -f po/${lang}.po ]; then
+ mo="${mo} ${lang}.mo"
+ fi
+ done
+
+ sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile || die
+ sed -i -e "/#!/s/python3/python/" pastebinit || die
+}
+
+src_compile() {
+ emake -C po
+ xsltproc --nonet \
+ "${EROOT}"usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
+ pastebinit.xml || die
+}
+
+src_install() {
+ dobin pastebinit utils/pbput
+ python_fix_shebang "${ED}usr/bin/${PN}"
+ dosym pbput /usr/bin/pbget
+ use crypt && dosym pbput /usr/bin/pbputs
+ dodoc README
+ doman pastebinit.1 utils/*.1
+ insinto /usr/share/locale
+ [[ -d po/mo ]] && doins -r po/mo/*
+ insinto /usr/share
+ doins -r pastebin.d
+}