summaryrefslogtreecommitdiff
path: root/app-text/pastebinit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /app-text/pastebinit
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'app-text/pastebinit')
-rw-r--r--app-text/pastebinit/Manifest4
-rw-r--r--app-text/pastebinit/metadata.xml1
-rw-r--r--app-text/pastebinit/pastebinit-1.5.1.ebuild41
3 files changed, 30 insertions, 16 deletions
diff --git a/app-text/pastebinit/Manifest b/app-text/pastebinit/Manifest
index 1bc8e86488be..bf155520d91b 100644
--- a/app-text/pastebinit/Manifest
+++ b/app-text/pastebinit/Manifest
@@ -1,3 +1,3 @@
DIST pastebinit_1.5.1.orig.tar.gz 51448 BLAKE2B a5cfa13c770e234d6e08d4f0b662c09398a5f20ac4e3f7c10ab086261923851239a3e6c1bda78ba6ba810f95cd90e6517b74aa41c5b5e3d50bca5b8c100aa594 SHA512 02b7faa54862d240eac3a8edaae2edb895cbb476cbf89dc71514a5a0a42aa2b0d26f07e5485627d1deb61f62e37018459e4d072bd4aacc886f259fced35e352c
-EBUILD pastebinit-1.5.1.ebuild 1335 BLAKE2B de1626383491379b3c9b04cef9aa19dbe36ce364fad754d196e1fa944e962ffda57f8f3c1b7f5dcde0bc65f93fd230886e8105f5e518cbcb345420d923a83127 SHA512 7ea3759337015fde7bd30476f9391e4910667d022f57da038edf8bf10758dce85669609c11b57210286f53edb1ba2f700558ffb81f4b257c1253bee08086031a
-MISC metadata.xml 326 BLAKE2B d50cef7d0035889868a74b6a2794648129bf06b854208dc28eefe82251c2c2bb4562d19103a6abae51e3f40afccfd901a4c1e2ed8bfcf9910fa99d9543b069c3 SHA512 cd582b088098d0163e91ea17e6b4fa2fb5b816e44590ff8f159730215d9b8118b747b43fdcb9d7a6cad3dfbfbcd8d8b6e29cd509b7a9d6e3b860c77c4ac10c4c
+EBUILD pastebinit-1.5.1.ebuild 1365 BLAKE2B 96c27cd94d5773265eb4ee2866d413380882046b5ffe6a5fd07cab769f3947d4d9fbfc238b3b8f37635ccbdc44d476a2a7fd319afee4eab4985f53b0aa5510ec SHA512 c3b70c11c241d6d038a8c172cc7d229b675ec91438084d1b4e5c8fcc54b362e72755ac4bb02410f7af29ba927956a0ccfafd1211cfe33efd208f4ec5c5b1e1fc
+MISC metadata.xml 350 BLAKE2B 48e5e06f98f204858522d5d157b7739cc8b4e6d9b22ebadd9318fdded30361594ca8e5ebc8b64dc26135b60de12adac9dece6560a0a68fa7f49876e63c90d1b5 SHA512 19b844196638bcb27fa6dbcd46516e0ca0a1861737fd29f196fddbe0489a077d11bba1efac5f21c395616923dd67b55e3797e508fd3ae48516cc4991afd54bda
diff --git a/app-text/pastebinit/metadata.xml b/app-text/pastebinit/metadata.xml
index c5629ce6ee70..6a9946b0c43c 100644
--- a/app-text/pastebinit/metadata.xml
+++ b/app-text/pastebinit/metadata.xml
@@ -2,6 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!--maintainer-needed-->
+ <stabilize-allarches/>
<use>
<flag name="crypt">Install pbputs for gpg-encrypted pastes</flag>
</use>
diff --git a/app-text/pastebinit/pastebinit-1.5.1.ebuild b/app-text/pastebinit/pastebinit-1.5.1.ebuild
index ae5a31bb904b..7a0e41a109ba 100644
--- a/app-text/pastebinit/pastebinit-1.5.1.ebuild
+++ b/app-text/pastebinit/pastebinit-1.5.1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="xml"
inherit python-single-r1
+MY_P="${PN}_${PV}"
DESCRIPTION="A software that lets you send anything you want directly to a pastebin"
HOMEPAGE="https://launchpad.net/pastebinit"
-MY_P="${PN}_${PV}"
SRC_URI="mirror://ubuntu/pool/main/p/${PN}/${MY_P}.orig.tar.gz"
LICENSE="GPL-2"
@@ -19,42 +19,55 @@ IUSE="crypt"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+BDEPEND="app-text/docbook-xsl-stylesheets"
+RDEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep '
- dev-python/configobj[${PYTHON_MULTI_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
')
- crypt? ( app-crypt/gnupg )"
-DEPEND="app-text/docbook-xsl-stylesheets"
+ crypt? ( app-crypt/gnupg )
+"
src_prepare() {
local mo=""
for lang in ${LINGUAS}; do
- if [ -f po/${lang}.po ]; then
+ if [[ -f po/${lang}.po ]]; then
mo="${mo} ${lang}.mo"
fi
done
sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile || die
- eapply_user
+
+ default
}
src_compile() {
emake -C po
xsltproc --nonet \
- "${EROOT}"/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
+ "${BROOT}"/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
pastebinit.xml || die
}
src_install() {
dobin pastebinit utils/pbput
+
python_fix_shebang "${ED}/usr/bin/${PN}"
+
dosym pbput /usr/bin/pbget
- use crypt && dosym pbput /usr/bin/pbputs
+
+ if use crypt; then
+ dosym pbput /usr/bin/pbputs
+ fi
+
dodoc README
doman pastebinit.1 utils/*.1
- insinto /usr/share/locale
- [[ -d po/mo ]] && doins -r po/mo/*
+
+ if [[ -d po/mo ]]; then
+ insinto /usr/share/locale
+ doins -r po/mo/*
+ fi
+
insinto /usr/share
doins -r pastebin.d
}