summaryrefslogtreecommitdiff
path: root/app-text/pastebinit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/pastebinit
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/pastebinit')
-rw-r--r--app-text/pastebinit/Manifest5
-rw-r--r--app-text/pastebinit/metadata.xml10
-rw-r--r--app-text/pastebinit/pastebinit-1.5.ebuild57
3 files changed, 72 insertions, 0 deletions
diff --git a/app-text/pastebinit/Manifest b/app-text/pastebinit/Manifest
new file mode 100644
index 000000000000..00fb78165da0
--- /dev/null
+++ b/app-text/pastebinit/Manifest
@@ -0,0 +1,5 @@
+DIST pastebinit-1.5.tar.bz2 42941 SHA256 42e5a84ce7e46825fb3b6478e11893fad357197327257e474bd0d3549f438457 SHA512 cc4b7c46ab7932be3a1064ce7a1d91da3ebf4b132ad44b0090c8d431bfc68e945357344e59ac1239e37b3178de124930c5c8dc552b42f16c39c0452ac9ab8099 WHIRLPOOL 0d20dd1ab5cb10436fc23fae27f090195400cfcfca1b24b860e27f1e5d38d7341c08ae1c8d7cc747e4127e3c8ae634355f796a6308a5a61671210c9581b22481
+EBUILD pastebinit-1.5.ebuild 1340 SHA256 f32f009c3754dba606934f15e63e7f0bf993fdbd1a7ac267202147849bda0f8a SHA512 7f2cab15367a685f65881271f6860d5569d6d021fe18d66f190dbb9005bd0fb288fa68932586052443ab5457121b7759040d1ee390d52b7616e828c0bdd673e5 WHIRLPOOL d0165e41e5eaf3239ab4d0e7f5dce868b2f74414a5778b08278f786671497d0c14f0e970e65f6d59278fd24e59ca494a5201037da32d915aa26774558b8ceac6
+MISC ChangeLog 3278 SHA256 a6571f9d6a1f3284fe0deab0c32606f00e6372ca12acbb07e7e2a434ccadb869 SHA512 0f7f1e298f7b7ac2796dd3da34f72b9669b4df8754722fbcfe6580be6f1f9a06940c67e7457839455d51241c1faebaac0202e4535479fea4ee8b0cddb40f3fda WHIRLPOOL d32e180ba5906463d81bfb9d78c37126d296b1671c81595e0d3ea491287e8f3c40901a36d3a872e09785ce35c60e6eda37b193b0aad030e110833b6d13cff329
+MISC ChangeLog-2015 1760 SHA256 62cf3a38a86df230064778c80ae052c732729f2ef0dfe4b0ce6767ff955024c5 SHA512 e55b8950c931deefa717f39f6d7d71772f83e934a36448f9bf5337e5cbce22f09f5647ea4c955379f0a13e01da811810f525d1be87f39ced7e132f7d0c2ca264 WHIRLPOOL afa1a90d51ed2b327218dfdf0806959955f2a463904df6fc2f610b752dc37b5d3ce2032bfb31cd843a44751db369bd4158cfd260f93dbf48b2c3bb2f1d8233ab
+MISC metadata.xml 300 SHA256 bba8c08801e22b77c3dcfe761fc04b3f60335314185a2730fe98c16611df87e7 SHA512 7dc26c0febbda314bdcba49514f0222c0cca81d0fc20a0576061b406c1ba388a0d190888b98f61291b4b3e251115c0417ea6a6e2aebae1d32678d182741fb39f WHIRLPOOL cfb5210e91c692076f13da16a6a36d9c1d513c38246a3dd373fb37722f712848c4d8ebe058e21563ec9acb69c0648b8d459625c5f48725b08c9db397cd3d062f
diff --git a/app-text/pastebinit/metadata.xml b/app-text/pastebinit/metadata.xml
new file mode 100644
index 000000000000..eaf351ef1efe
--- /dev/null
+++ b/app-text/pastebinit/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="crypt">Install pbputs for gpg-encrypted pastes</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">pastebinit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pastebinit/pastebinit-1.5.ebuild b/app-text/pastebinit/pastebinit-1.5.ebuild
new file mode 100644
index 000000000000..9e79db0da019
--- /dev/null
+++ b/app-text/pastebinit/pastebinit-1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="A software that lets you send anything you want directly to a pastebin"
+HOMEPAGE="https://launchpad.net/pastebinit"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="crypt"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ crypt? ( app-crypt/gnupg )"
+DEPEND="app-text/docbook-xsl-stylesheets"
+
+src_prepare() {
+ local mo=""
+
+ for lang in ${LINGUAS}; do
+ if [ -f po/${lang}.po ]; then
+ mo="${mo} ${lang}.mo"
+ fi
+ done
+
+ sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile || die
+ sed -i -e "/#!/s/python3/python/" pastebinit || die
+}
+
+src_compile() {
+ emake -C po
+ xsltproc --nonet \
+ "${EROOT}"usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
+ pastebinit.xml || die
+}
+
+src_install() {
+ dobin pastebinit utils/pbput
+ python_fix_shebang "${ED}usr/bin/${PN}"
+ dosym pbput /usr/bin/pbget
+ use crypt && dosym pbput /usr/bin/pbputs
+ dodoc README
+ doman pastebinit.1 utils/*.1
+ insinto /usr/share/locale
+ [[ -d po/mo ]] && doins -r po/mo/*
+ insinto /usr/share
+ doins -r pastebin.d
+}