summaryrefslogtreecommitdiff
path: root/app-text/pastebinit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-text/pastebinit
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-text/pastebinit')
-rw-r--r--app-text/pastebinit/Manifest4
-rw-r--r--app-text/pastebinit/files/pastebinit-1.5.1-distro.patch13
-rw-r--r--app-text/pastebinit/pastebinit-1.5.1-r1.ebuild74
-rw-r--r--app-text/pastebinit/pastebinit-1.5.1.ebuild4
4 files changed, 92 insertions, 3 deletions
diff --git a/app-text/pastebinit/Manifest b/app-text/pastebinit/Manifest
index ce15f677273f..6b8130ba84ca 100644
--- a/app-text/pastebinit/Manifest
+++ b/app-text/pastebinit/Manifest
@@ -1,3 +1,5 @@
+AUX pastebinit-1.5.1-distro.patch 379 BLAKE2B c843acae6267fe2408945cabc0951f9d8cf01cbec1e472658369782a7ded31670eda5a4778df0d89597b5579cf647e47140842cc35b6c3f16eb704d3fb3eefd1 SHA512 bf75d156035e2e08752d7ecd371f5a92b4eb88ea834b4c7a23a533b6c650069d68d0069220e1f0eb04adf8e399c7cf2cf49c93047b42b6fd9d0d2e529dd1dda1
DIST pastebinit_1.5.1.orig.tar.gz 51448 BLAKE2B a5cfa13c770e234d6e08d4f0b662c09398a5f20ac4e3f7c10ab086261923851239a3e6c1bda78ba6ba810f95cd90e6517b74aa41c5b5e3d50bca5b8c100aa594 SHA512 02b7faa54862d240eac3a8edaae2edb895cbb476cbf89dc71514a5a0a42aa2b0d26f07e5485627d1deb61f62e37018459e4d072bd4aacc886f259fced35e352c
-EBUILD pastebinit-1.5.1.ebuild 1372 BLAKE2B 73a7c713ace2c6c7f51351986745ac86db10ef4755bbc28f59d54b2aa97a121f02d16b1d15376a7fb69ac65ee68782d355b84343d275fbaf827e74b906614579 SHA512 c9048c262e4f7a2df4c66946b25bf74656d1d663bfdc81000888269219ed4f7e4e0360e09fb16f56e527a15dc0bbca065dfa017586d3f6a32ba42df2b3f59fed
+EBUILD pastebinit-1.5.1-r1.ebuild 1509 BLAKE2B 7487dc439a980655e92ccf6b7e36cbc15e21ef08e357363d9c0744150b67e0288f5fe143fb7b0c5c031bbbf8c3db273240f10ad7be6f6c3512d1f728072fe518 SHA512 a6bd72802c296a4e9daa2751f592a92954430c0dca954d98df22397b2eed6b4e8cc389e440da073b9339859df333c6ef7c82fbeaaa2d1869f3d152e42a78700b
+EBUILD pastebinit-1.5.1.ebuild 1372 BLAKE2B 573b534cfe6cb2d253a3955437172d1e2c7114c1abc6295e62db9439c61115f3fcf648d9953b6c04aeff306e349f138ec3cc5a6683a495f2a2fc813521163345 SHA512 0dc376c65b67fe0cf1830da4b31894477ded82dc7dcef33e2256bf291796c543f378bda8a7748841482d02128853b130e21eaea06380ab1f4c1af35ce923ec1d
MISC metadata.xml 351 BLAKE2B 5c950ed10e95959cec08ad45580f8a3df458f9735a9267f6df6b95dab63133d1345ead61033d452a050dc07cf1468a4b68fee719760350c3163aeb350b359ba2 SHA512 d43e2089dccaa9a34cd76dbbc2421e1d9506be7c4958da5722631c46db42fd4ad3e5a460a5058bbbe51326cf39550a1a1385f3eafa959b49937a48a5dea28f85
diff --git a/app-text/pastebinit/files/pastebinit-1.5.1-distro.patch b/app-text/pastebinit/files/pastebinit-1.5.1-distro.patch
new file mode 100644
index 000000000000..ee7245c03faa
--- /dev/null
+++ b/app-text/pastebinit/files/pastebinit-1.5.1-distro.patch
@@ -0,0 +1,13 @@
+Fix DeprecationWarning
+--- a/pastebinit
++++ b/pastebinit
+@@ -32,8 +32,7 @@
+ # Now try to override it with a distributor pastebin
+ try:
+ import distro
+- release = distro.linux_distribution(
+- full_distribution_name=False)[0].lower()
++ release = distro.id()
+ if release == 'debian':
+ defaultPB = "paste.debian.net"
+ elif release == 'fedora':
diff --git a/app-text/pastebinit/pastebinit-1.5.1-r1.ebuild b/app-text/pastebinit/pastebinit-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..7eabfda86fb8
--- /dev/null
+++ b/app-text/pastebinit/pastebinit-1.5.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+inherit optfeature python-single-r1
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="A software that lets you send anything you want directly to a pastebin"
+HOMEPAGE="https://launchpad.net/pastebinit"
+SRC_URI="mirror://ubuntu/pool/main/p/${PN}/${MY_P}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="man"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/configobj[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ sys-devel/gettext
+ man? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-distro.patch )
+
+src_prepare() {
+ default
+ python_fix_shebang "${S}"/${PN}
+}
+
+src_compile() {
+ emake -C po
+
+ if use man; then
+ ebegin "Generating a manpage with xsltproc"
+ xsltproc --nonet \
+ "${BROOT}"/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
+ pastebinit.xml
+ eend $?
+ fi
+}
+
+src_install() {
+ dobin pastebinit utils/pbput
+ dosym pbput /usr/bin/pbget
+ dosym pbput /usr/bin/pbputs
+
+ einstalldocs
+ doman utils/*.1
+ use man && doman pastebinit.1
+
+ insinto /usr/share/locale
+ doins -r po/mo/*
+
+ insinto /usr/share
+ doins -r pastebin.d
+}
+
+pkg_postinst() {
+ optfeature "identification of your distribution" dev-python/distro
+ optfeature "pbput and pbputs scripts" app-arch/xz-utils
+ optfeature "pbget and pbputs scripts" app-crypt/gnupg
+}
diff --git a/app-text/pastebinit/pastebinit-1.5.1.ebuild b/app-text/pastebinit/pastebinit-1.5.1.ebuild
index 550104a796b0..2813fc45c493 100644
--- a/app-text/pastebinit/pastebinit-1.5.1.ebuild
+++ b/app-text/pastebinit/pastebinit-1.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml"
inherit python-single-r1