summaryrefslogtreecommitdiff
path: root/app-text/pastebinit/pastebinit-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-22 01:55:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-22 01:55:45 +0000
commitb2c59335bfbeb25c5644f32172e1e9b23c447710 (patch)
tree0e8e19f47e39be0a7b9b06cb86db760c6d6b5965 /app-text/pastebinit/pastebinit-1.5.1.ebuild
parent427ba64bd6bcdd59a1ae9bc7c5cec0299d135413 (diff)
gentoo auto-resync : 22:12:2022 - 01:55:45
Diffstat (limited to 'app-text/pastebinit/pastebinit-1.5.1.ebuild')
-rw-r--r--app-text/pastebinit/pastebinit-1.5.1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/app-text/pastebinit/pastebinit-1.5.1.ebuild b/app-text/pastebinit/pastebinit-1.5.1.ebuild
deleted file mode 100644
index 1f6b2139f192..000000000000
--- a/app-text/pastebinit/pastebinit-1.5.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml(+)"
-inherit python-single-r1
-
-MY_P="${PN}_${PV}"
-DESCRIPTION="A software that lets you send anything you want directly to a pastebin"
-HOMEPAGE="https://launchpad.net/pastebinit"
-SRC_URI="mirror://ubuntu/pool/main/p/${PN}/${MY_P}.orig.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-IUSE="crypt"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="app-text/docbook-xsl-stylesheets"
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/configobj[${PYTHON_USEDEP}]
- ')
- crypt? ( app-crypt/gnupg )
-"
-
-src_prepare() {
- local mo=""
-
- for lang in ${LINGUAS}; do
- if [[ -f po/${lang}.po ]]; then
- mo="${mo} ${lang}.mo"
- fi
- done
-
- sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile || die
-
- default
-}
-
-src_compile() {
- emake -C po
- xsltproc --nonet \
- "${BROOT}"/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
- pastebinit.xml || die
-}
-
-src_install() {
- dobin pastebinit utils/pbput
-
- python_fix_shebang "${ED}/usr/bin/${PN}"
-
- dosym pbput /usr/bin/pbget
-
- if use crypt; then
- dosym pbput /usr/bin/pbputs
- fi
-
- dodoc README
- doman pastebinit.1 utils/*.1
-
- if [[ -d po/mo ]]; then
- insinto /usr/share/locale
- doins -r po/mo/*
- fi
-
- insinto /usr/share
- doins -r pastebin.d
-}