summaryrefslogtreecommitdiff
path: root/app-text/par
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-text/par
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-text/par')
-rw-r--r--app-text/par/Manifest2
-rw-r--r--app-text/par/par-1.53.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/app-text/par/Manifest b/app-text/par/Manifest
index 02c9ae188b61..41fd38ba3267 100644
--- a/app-text/par/Manifest
+++ b/app-text/par/Manifest
@@ -1,3 +1,5 @@
+DIST Par-1.53.0.tar.gz 52209 BLAKE2B 4069f75e1d0ff397938941ab58020c41cb1b896ab91b370c4f9c9a4d4eea1fe695cc0c27b0129780d40b7274e355ac1f41a933d051bffebc938c284e71971fe6 SHA512 3f8ac57fe19ebcf427b11f4d79f2c5cc9286c1439c38a53d45bd29b9219369db2798efbd0e203ac359d59ebbdd3ead1c50ae75352a1ffc568d4d3b9ad50642b1
DIST Par152.tar.gz 47999 BLAKE2B 0f76abde64d00d0511d9b0b0ce2a97b13917e08fe3bd1c69fa98ca19dff75a2b55a21f5eaa8bfd0660b6523336de6c29b2a58647196ff6af8c24ec156a426bb0 SHA512 f5a46da4b693e6a3d15ccd57e24ee9b0332ebfbcfc88da9ef0731e18932ba6f0adde7691a233264d6361e8903ff7e2263f71885a415c896dc4c45a0d05b1978e
EBUILD par-1.52-r1.ebuild 722 BLAKE2B f9aca7e9d0a3d81f5971cfbaf0eb30477d87dca750d7ec2a5993178662f256ba5c7da487395690f3b1f437a503f3fdea7eef61b0e033a8d562e5ef14bd28cfaf SHA512 0625322d759184ca511567f15594cd44691699df0d0df985ddac874af5609e95c40bd42a522152d9223ded7432894cf94c7c4e3c75fc98ef464d92f026d01028
+EBUILD par-1.53.0.ebuild 757 BLAKE2B 5942b5bf3730973502c7138eff2cde4e0ea0b7c70288ca631f9bdd8e96fc449873f48cf97fbad111fcb8e2402873f79bbbf55993133ed3b2d82ea06638dc6795 SHA512 8cbd7d8edbf1ec06fd776948d21bfb7300f585b019cd3277b259eccc94feebcefd6f56c3cbec3f094e767428a57a324d679915a5854ea9da8be6a21c8f7dd9f5
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-text/par/par-1.53.0.ebuild b/app-text/par/par-1.53.0.ebuild
new file mode 100644
index 000000000000..3165b8c44367
--- /dev/null
+++ b/app-text/par/par-1.53.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="Par-${PV}"
+DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
+HOMEPAGE="http://www.nicemice.net/par/"
+SRC_URI="http://www.nicemice.net/par/${MY_P}.tar.gz"
+
+LICENSE="|| ( MIT par )"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="!dev-util/par
+ !app-arch/par"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake -f protoMakefile CC="$(tc-getCC) ${CFLAGS} -c" \
+ LINK1="$(tc-getCC) ${LDFLAGS}"
+}
+
+src_install() {
+ newbin par par-format
+ doman par.1
+ dodoc releasenotes par.doc
+}
+
+src_test() {
+ emake -f protoMakefile test
+}