summaryrefslogtreecommitdiff
path: root/app-text/paps/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/paps/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/paps/files')
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch36
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch20
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-empty-file.patch23
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-freetype-include.patch14
4 files changed, 93 insertions, 0 deletions
diff --git a/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch b/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch
new file mode 100644
index 000000000000..ec4ba8b2b180
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch
@@ -0,0 +1,36 @@
+--- paps-0.6.8/configure.in
++++ paps-0.6.8/configure.in
+@@ -18,4 +18,6 @@
+
+ DX_INIT_DOXYGEN(libpaps, doxygen.cfg, doxygen-doc)
+
++PKG_CHECK_MODULES([PANGO], [pangoft2])
++
+ AC_OUTPUT(Makefile src/Makefile)
+--- paps-0.6.8/src/Makefile.am
++++ paps-0.6.8/src/Makefile.am
+@@ -7,21 +7,19 @@
+ bin_PROGRAMS = paps
+ paps_CFLAGS = -Wall
+ paps_SOURCES = paps.c
+-paps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+-paps_LDFLAGS = `pkg-config --libs pangoft2`
++paps_LDADD = $(lib_LIBRARIES) $(all_libraries) $(PANGO_LIBS)
+ paps_DEPENDENCIES = $(lib_LIBRARIES)
+
+ EXTRA_DIST = test_libpaps.c paps.1
+
+ # set the include path found by configure
+-INCLUDES= $(all_includes) `pkg-config --cflags pangoft2`
++INCLUDES= $(all_includes) $(PANGO_CFLAGS)
+
+ # Test program
+ noinst_PROGRAMS = test_libpaps
+
+
+ test_libpaps_SOURCES = test_libpaps.c
+-test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+-test_libpaps_LDFLAGS = `pkg-config --libs pangoft2`
++test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries) $(PANGO_LIBS)
+ test_libpaps_DEPENDENCIES = $(lib_LIBRARIES)
+
diff --git a/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch b/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch
new file mode 100644
index 000000000000..baba74b4b8bb
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch
@@ -0,0 +1,20 @@
+--- paps-0.6.8/acinclude.m4
++++ paps-0.6.8/acinclude.m4
+@@ -78,7 +78,7 @@
+ AC_PATH_TOOL([$1], [$2])
+ if test "$DX_FLAG_[]DX_CURRENT_FEATURE$$1" = 1; then
+ AC_MSG_WARN([$2 not found - will not DX_CURRENT_DESCRIPTION])
+- AC_SUBST([DX_FLAG_[]DX_CURRENT_FEATURE], 0)
++ AC_SUBST([DX_FLAG_]DX_CURRENT_FEATURE, 0)
+ fi
+ ])
+
+@@ -101,7 +101,7 @@
+ # ----------------------------------------------------------
+ # Turn off the DX_CURRENT_FEATURE if the required feature is off.
+ AC_DEFUN([DX_CLEAR_DEPEND], [
+-test "$DX_FLAG_$1" = "$2" || AC_SUBST([DX_FLAG_[]DX_CURRENT_FEATURE], 0)
++test "$DX_FLAG_$1" = "$2" || AC_SUBST([DX_FLAG_]DX_CURRENT_FEATURE, 0)
+ ])
+
+ # DX_FEATURE_ARG(FEATURE, DESCRIPTION,
diff --git a/app-text/paps/files/paps-0.6.8-fix-empty-file.patch b/app-text/paps/files/paps-0.6.8-fix-empty-file.patch
new file mode 100644
index 000000000000..ae334d1d28c0
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-empty-file.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/show_bug.cgi?id=566050#c2
+
+--- paps-0.6.8/src/paps.c
++++ paps-0.6.8/src/paps.c
+@@ -569,11 +569,14 @@
+
+ fclose (file);
+
+- /* Add a trailing new line if it is missing */
+- if (inbuf->str[inbuf->len-1] != '\n')
+- g_string_append(inbuf, "\n");
++ if (inbuf->len) {
++ /* Add a trailing new line if it is missing */
++ if (inbuf->str[inbuf->len-1] != '\n')
++ g_string_append(inbuf, "\n");
+
+- text = inbuf->str;
++ text = inbuf->str;
++ } else
++ text = g_strdup("\n");
+ g_string_free (inbuf, FALSE);
+
+ return text;
diff --git a/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch b/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch
new file mode 100644
index 000000000000..ab97d22a2957
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch
@@ -0,0 +1,14 @@
+--- paps-0.6.8/src/libpaps.c
++++ paps-0.6.8/src/libpaps.c
+@@ -25,8 +25,9 @@
+
+ #include <pango/pango.h>
+ #include <pango/pangoft2.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
++#include <ft2build.h>
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <stdio.h>