summaryrefslogtreecommitdiff
path: root/app-text/paperwork-backend
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /app-text/paperwork-backend
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'app-text/paperwork-backend')
-rw-r--r--app-text/paperwork-backend/Manifest2
-rw-r--r--app-text/paperwork-backend/paperwork-backend-1.2.3.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-text/paperwork-backend/Manifest b/app-text/paperwork-backend/Manifest
index 7f7030ffef93..6ca51898615c 100644
--- a/app-text/paperwork-backend/Manifest
+++ b/app-text/paperwork-backend/Manifest
@@ -1,3 +1,5 @@
DIST paperwork-backend-1.2.2.tar.gz 64271 BLAKE2B 8261f64585d113a0a06a556e93c06cb528c60e1a906e2926aa55a39d363988ba9949ee7c51ab83efb683aa9beb986883e12e0895063e1a350a4ecdc23bb71cf6 SHA512 6fbf00f657134f1aeae0850f58adce0cef4dc292898db3fde725d404bea5d2fc73c386ce8c1f37ae7980997c23ba9489c13e02e3e9d056cca8014cf5691e5ef8
+DIST paperwork-backend-1.2.3.tar.gz 64676 BLAKE2B 9d6b43b7fea5a246e78d6cb250cbe94dc33dd0afea086933819d3392242c02c47789465e710313fd00b3e1731d936fa52d3086f00ba51a5c7cbaa4a9dfb2870a SHA512 1d79fa258c9e08d582797444257877e87bd8bb8413cea48419c6fea76d4b023b18fcb4d5831e09eca1561bea852e27f105841b04a44c319a0f9d7fc102c2c4d5
EBUILD paperwork-backend-1.2.2.ebuild 902 BLAKE2B 94903cbe8f24b3a4fa40e110f41b898511b33e78790e768c00b1e170dfbf8393788ed15dc1076cb448178cea6e0ad7669584dad6bf98dfe036d2f1a8d90d91d0 SHA512 6aa20f76e3ce2c17efbd16fbdff34db4a02a43b56ea5bccf4c4e28325c1e3bf27baedc21ae5bdcae335e4c136d8e26d392d5d647759642b72df9a26c798c2e43
+EBUILD paperwork-backend-1.2.3.ebuild 902 BLAKE2B e2cf019b547508a2810721634981f06e0a2e6fc6bd927e24a8d88cf9c0a886380a90252c7c89524c095259de7edc807c5a82ebdb33dbea8f1909d37e8acc268e SHA512 4bb4b41413b663425ffed140f57dd21764c06bb9a66befdb4eb3de0436307bdd29d83232f0fc188f9011b60dada4b7fb9f1c97d6548bf728bf6a57ca97e85f9c
MISC metadata.xml 358 BLAKE2B cb88562d44bff3ee72bc171fe94d05ad0e21cdcbf56242ecba5b5401eebf9063c851f69f211d0c2bbdedd638a9626833a5c36169e7d334bffe1703981ccf6813 SHA512 1a5a81b753e23232ec0fa2e5239d80ae70a589403a1cec20191590f4d5741fe2519a389ecad905e4fd89d148f8420dc602016fe92f10fe03ebea70508d4d361d
diff --git a/app-text/paperwork-backend/paperwork-backend-1.2.3.ebuild b/app-text/paperwork-backend/paperwork-backend-1.2.3.ebuild
new file mode 100644
index 000000000000..f0f34d215f9d
--- /dev/null
+++ b/app-text/paperwork-backend/paperwork-backend-1.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend part of Paperwork (Python API, no UI)"
+HOMEPAGE="https://github.com/openpaperwork/paperwork-backend"
+SRC_URI="https://github.com/openpaperwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-text/poppler[introspection]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"