summaryrefslogtreecommitdiff
path: root/app-text/paperwork-backend
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
commit3f9a144d38a57497a44a583d11a6e3dfbe8319d5 (patch)
treecb0e6beb4b79e1f7ccd95c75c9f434fdad11a071 /app-text/paperwork-backend
parent800c4c398cad9dd837da33062e71ccc84114fe05 (diff)
gentoo auto-resync : 20:09:2022 - 23:24:40
Diffstat (limited to 'app-text/paperwork-backend')
-rw-r--r--app-text/paperwork-backend/Manifest2
-rw-r--r--app-text/paperwork-backend/paperwork-backend-2.1.1-r1.ebuild (renamed from app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild)27
2 files changed, 23 insertions, 6 deletions
diff --git a/app-text/paperwork-backend/Manifest b/app-text/paperwork-backend/Manifest
index 6addeab28d47..74ae0a83b9ba 100644
--- a/app-text/paperwork-backend/Manifest
+++ b/app-text/paperwork-backend/Manifest
@@ -1,5 +1,5 @@
DIST paperwork-backend-2.1.0.tar.gz 1352553 BLAKE2B 84bf9f34be50c2cd762c1afb496e4625bed50018242e94925ad4d5428228fadc9ac8d3866f8fbb9f0a78d049599048db62c6d7201852638cc5ad0674ebc791f0 SHA512 72cf3176091d899433a50d8a166a2505f0be9e5917df311a6f5139af472363df427102dcde99e6097b11f6aa26571bdaba06047fafd2365b4dedec0d3a47da7a
DIST paperwork-backend-2.1.1.tar.gz 1383107 BLAKE2B 0e814a829581fe6322cc0ae44e9e3a20a2fc066e9be5de038c4d08b9d85218961ca87777271ebc646b03425e78017109ddf35c05a4b11e8fcc3bb4b6d10a6273 SHA512 ab75aaf01571eaa52a283ac6e1b9ff080d09e2514e1efb98bc96e9986acf85ec2ab2d94fc27ba15230370c642e39fddf6e11922a3d18b16af38f4281ff9c628f
EBUILD paperwork-backend-2.1.0.ebuild 959 BLAKE2B b46571e2a34860e07c796aed27ba420ecedcf7dbcf908fb969b51544acf3cef45c96b54c96de717d8adc843413d7677c58b4ebf5a2c28f4712194f5230718c10 SHA512 1ef2da67bc7e325ffc22b216f01f78dd561fe7de4c1a43d6b7b48ca92683fcac55a91cff3d3be5ec1833f9ccf58996ee42567760c0d51514fd3cbd9e0dd719b7
-EBUILD paperwork-backend-2.1.1.ebuild 991 BLAKE2B ffcd34b4d13a58423a09a3d0bb9cfa54b461d9b8c19056a6a1853dd7ad3e6fb630ebc1f81ea017ee2385d0a95768dcff32ee44bcf7081044594a3e28237a0297 SHA512 bf4275a578eae3f93975022e5f84e46516bd508b33ca361b03ca4dcab27a234fc88ac274ec2d711d5b93548eef2d6b3f73f46f7de7ef80bd1eaf5fa88699ea22
+EBUILD paperwork-backend-2.1.1-r1.ebuild 1312 BLAKE2B b34d88703fd385d884d583401cf0ae4b53fa260e800aa5e634d5e4f7a972f37158e788118a07a4b0495b1c1dc070296c2f1871d8386a8bb8e15b26d409f0bc6c SHA512 51c39ff116fc98d61b080e4ec8f9786c2e21f8634dbb0bfdee062c2d343092e1deff6b58cddd968ed42bb7fc83fbc97629abced3c49a2305d87ac789347878f8
MISC metadata.xml 343 BLAKE2B c205d91c4a58119baa58d40a20915a1cbf44ee65b05d2e42150b45010c0802512008c53c487b1622f6370c46f741082347ec6241290ff1ec93142ad8fb4a9081 SHA512 e0b32b862f07314143878a643d0c8475b1d17ccf7eaddeb9cf77a787e68ebd231ccb4176c71a65ac47eefa97af2a04fedce0cb4efda24c08452c63d390a4dd8f
diff --git a/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild b/app-text/paperwork-backend/paperwork-backend-2.1.1-r1.ebuild
index f5bcf8a9e058..fc9f7013f9c4 100644
--- a/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild
+++ b/app-text/paperwork-backend/paperwork-backend-2.1.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-DISTUTILS_USE_SETUPTOOLS=bdepend
+
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,9 +14,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="app-text/poppler[introspection]
+RDEPEND="
+ app-text/openpaperwork-core[${PYTHON_USEDEP}]
+ app-text/openpaperwork-gtk[${PYTHON_USEDEP}]
+ app-text/poppler[introspection]
dev-python/distro[${PYTHON_USEDEP}]
dev-python/Levenshtein[${PYTHON_USEDEP}]
dev-python/natsort[${PYTHON_USEDEP}]
@@ -28,6 +30,21 @@ RDEPEND="app-text/poppler[introspection]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/whoosh[${PYTHON_USEDEP}]
- sci-libs/scikit-learn[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ media-libs/libinsane
+ )
+"
+
distutils_enable_tests unittest
+
+src_prepare() {
+ # remove dep to allow both old python-Levenshtein and new
+ # Levenshtein packages
+ sed -i -e '/python-Levenshtein/d' setup.py || die
+ distutils-r1_src_prepare
+}