summaryrefslogtreecommitdiff
path: root/app-text/paper-clip/paper-clip-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
commit32b8124b0a5827960601f2183a970103b3d231b7 (patch)
treefebd1cb81d2417f5452d0e21f81d06663f12caa3 /app-text/paper-clip/paper-clip-9999.ebuild
parent89e7f1cd6dd17f245898939477ef38d45dd112b9 (diff)
gentoo auto-resync : 19:12:2023 - 07:53:49
Diffstat (limited to 'app-text/paper-clip/paper-clip-9999.ebuild')
-rw-r--r--app-text/paper-clip/paper-clip-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-text/paper-clip/paper-clip-9999.ebuild b/app-text/paper-clip/paper-clip-9999.ebuild
index 2dc0892a58ef..3d5055cd6861 100644
--- a/app-text/paper-clip/paper-clip-9999.ebuild
+++ b/app-text/paper-clip/paper-clip-9999.ebuild
@@ -10,19 +10,21 @@ inherit gnome2-utils meson vala xdg
DESCRIPTION="Edit the title, author, keywords and more details of PDF documents"
HOMEPAGE="https://github.com/Diego-Ivan/Paper-Clip/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/Diego-Ivan/${REAL_PN}.git"
else
SRC_URI="https://github.com/Diego-Ivan/${REAL_PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
S="${WORKDIR}/${REAL_PN}-${PV}"
+
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
-RESTRICT="test" # Only validations, appdata one fails.
+RESTRICT="test" # Only validations, the appdata one fails.
RDEPEND="
app-text/poppler:=[cairo,introspection]
@@ -53,9 +55,9 @@ src_install() {
einstalldocs
# Symlink "pdf-metadata-editor" (old name?) to "${PN}"
- dosym -r /usr/bin/pdf-metadata-editor /usr/bin/${PN}
+ dosym -r /usr/bin/pdf-metadata-editor "/usr/bin/${PN}"
- mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+ mv "${ED}/usr/share/appdata" "${ED}/usr/share/metainfo" || die
}
pkg_postinst() {