summaryrefslogtreecommitdiff
path: root/app-text/pandoc-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-text/pandoc-bin
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-text/pandoc-bin')
-rw-r--r--app-text/pandoc-bin/Manifest4
-rw-r--r--app-text/pandoc-bin/metadata.xml26
-rw-r--r--app-text/pandoc-bin/pandoc-bin-2.18.ebuild44
3 files changed, 74 insertions, 0 deletions
diff --git a/app-text/pandoc-bin/Manifest b/app-text/pandoc-bin/Manifest
new file mode 100644
index 000000000000..f40bf49b7b97
--- /dev/null
+++ b/app-text/pandoc-bin/Manifest
@@ -0,0 +1,4 @@
+DIST pandoc-2.18-linux-amd64.tar.gz 16713899 BLAKE2B 89f2166fb93793c07af9d3ddff56767e4072500b80cd462a498f5534fdbfba974fa517fa05c3bfeaf44179cd23b6d53fc5daed5916f18fce13df4486040610ca SHA512 ec0285e9a1640e7594d5bdca3fcdc738b2139e20f4a4f75b0f49ff76d2d2f5a0e8b90912e63a93e787c57f18eb3d155f214f088e55b435ef03acb8cfbf92272b
+DIST pandoc-2.18-linux-arm64.tar.gz 18522530 BLAKE2B 84e2479a77c12ace90a93ed9b66be2abdec357e0b4338143db8a9318cd48e76852d9fc12ceb8bd795860412a2e98d11a4d1e54bf74bdf68494c699fd5878c818 SHA512 e2be1473edeba12996a9eb7af3fe7dfd860adb1054446d2b93db6d712708282424628b14fea8809dba903e93daa1626a0dc3e1304af33b77e9da298c8fd7885b
+EBUILD pandoc-bin-2.18.ebuild 990 BLAKE2B d155ff808a25b86ab0e86a6e57f1b4ab6f3a4a819a3a8149f0b832520811d7f2b3fe82d69b28ce38b1b583b89b886b1092a823944f92c1536131b1027300e9da SHA512 2bd39771dcfe4ef3ac5c882b8d38a04570d5cf7eca730e3d683dca56ed4b4abf5e8a6cbe4130135cac60ac4d3e56326e8ea3c95fba3d3c7b728aebf9024d2a6d
+MISC metadata.xml 986 BLAKE2B 10ab442c2f7892545054ba2747c0cde115d9d875673c077d2cefcd035e2ecd6d04f2aef05ef9ca58a2150a983079ad8fbdc6910ca93fc14977409041e5f20201 SHA512 c8e241d4d7bba0a6f36320517d18fbb99922e32970d7771d5bbc80a8ecf5086f8f7d1eadd0188d457412a66db898d044074b4d4f0301aab1e19cd1213e562375
diff --git a/app-text/pandoc-bin/metadata.xml b/app-text/pandoc-bin/metadata.xml
new file mode 100644
index 000000000000..dd32ba2128b1
--- /dev/null
+++ b/app-text/pandoc-bin/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Pandoc is a Haskell library for converting from one markup format to
+ another, and a command-line tool that uses this library. It can read
+ markdown and (subsets of) reStructuredText, HTML, LaTeX and Textile, and it
+ can write markdown, reStructuredText, HTML, LaTeX, ConTeXt, Docbook,
+ OpenDocument, ODT, RTF, MediaWiki, Textile, groff man pages, plain text,
+ Emacs Org-Mode, EPUB, and S5 and Slidy HTML slide shows.
+ </longdescription>
+ <use>
+ <flag name="pandoc-symlink">
+ Install pandoc symlink that points to pandoc-bin
+ </flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/jgm/pandoc/issues/</bugs-to>
+ <remote-id type="github">jgm/pandoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/pandoc-bin/pandoc-bin-2.18.ebuild b/app-text/pandoc-bin/pandoc-bin-2.18.ebuild
new file mode 100644
index 000000000000..13a2ca157762
--- /dev/null
+++ b/app-text/pandoc-bin/pandoc-bin-2.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN//-bin/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Conversion between markup formats (binary package)"
+HOMEPAGE="https://pandoc.org/"
+
+BASE_URI="https://github.com/jgm/${MY_PN}/releases/download/${PV}/${MY_P}"
+SRC_URI="
+ amd64? ( ${BASE_URI}-linux-amd64.tar.gz )
+ arm64? ( ${BASE_URI}-linux-arm64.tar.gz )
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64" # Upstream provides only AMD and ARM 64-bit binaries
+IUSE="+pandoc-symlink"
+
+RDEPEND="pandoc-symlink? ( !${CATEGORY}/${MY_PN} )"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+QA_PRESTRIPPED="${QA_FLAGS_IGNORED}"
+
+src_unpack() {
+ default
+
+ # Manpages are gzipped
+ unpack "${S}"/share/man/man1/${MY_PN}.1.gz
+}
+
+src_install() {
+ newbin bin/${MY_PN} ${PN}
+ newman "${WORKDIR}"/${MY_PN}.1 ${PN}.1
+
+ if use pandoc-symlink ; then
+ dosym ${PN} /usr/bin/${MY_PN}
+ dosym ${PN}.1 /usr/share/man/man1/${MY_PN}.1
+ fi
+}