summaryrefslogtreecommitdiff
path: root/app-text/o3read/o3read-0.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/o3read/o3read-0.0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/o3read/o3read-0.0.4.ebuild')
-rw-r--r--app-text/o3read/o3read-0.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/o3read/o3read-0.0.4.ebuild b/app-text/o3read/o3read-0.0.4.ebuild
new file mode 100644
index 000000000000..9b39421c0634
--- /dev/null
+++ b/app-text/o3read/o3read-0.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Converts OpenOffice formats to text or HTML"
+HOMEPAGE="http://siag.nu/o3read/"
+SRC_URI="http://siag.nu/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RESTRICT=test
+
+src_prepare() {
+ sed \
+ -e 's:-o:$(LDFLAGS) -o:g' \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/g' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin o3read o3totxt o3tohtml utf8tolatin1
+ doman o3read.1 o3tohtml.1 o3totxt.1 utf8tolatin1.1
+}