summaryrefslogtreecommitdiff
path: root/app-text/nuspell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /app-text/nuspell
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest3
-rw-r--r--app-text/nuspell/metadata.xml14
-rw-r--r--app-text/nuspell/nuspell-3.0.0.ebuild43
3 files changed, 60 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
new file mode 100644
index 000000000000..856068c0104d
--- /dev/null
+++ b/app-text/nuspell/Manifest
@@ -0,0 +1,3 @@
+DIST nuspell-3.0.0.tar.gz 403043 BLAKE2B b437012e4fb327f13d9ff0944dadf7e865c670daf153be00dd48e9d2fc01c87d410ebd5aeaa094f6446d3035346738010cdba961cfaada3751bedce264beaa6a SHA512 d9cd7dd276e2bca43dec3abaf11c5206695949b9fda8c9b86f2772cc7e8fa95bf17c685a2ef9ca87fe3c4f0b55f2fcb435bc21c187355f5e3fa35dcafab2c8c2
+EBUILD nuspell-3.0.0.ebuild 1091 BLAKE2B 07c8fa7a2b9c03c18821ccd35bc1d9fa5f72490c4a9ec4d52cd4f4f90cb2d295771e2110b6ab50ab8c0bb34db075349735993e61f3d5ddca1380d5cec4e467f8 SHA512 eceed5f031c930296ed451dad77718cd07e4b052598026b4c59219467eb26c7eb050239d1869339791bd9e4bf437af9e54cefa1981ffe939394331a5dde8adff
+MISC metadata.xml 489 BLAKE2B 51835316b4f8b1b1a016324955d48f6f5126ef7b7caf11f4b46ea858469fc9ebe3154de4fbc99d528bfef3808fe7c95dd2f540038572ae640b00dad9fccbeacf SHA512 ea959020e4b2a90f475d296fd1a43c2ba8efc1c39f2dde70b930165bce165df1011e04af8f54b37740f28e009502a5c64ec0fdb2b7221003388cd47b1ccadeb5
diff --git a/app-text/nuspell/metadata.xml b/app-text/nuspell/metadata.xml
new file mode 100644
index 000000000000..6a10d096c251
--- /dev/null
+++ b/app-text/nuspell/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription>
+ Spell checker library and command-line program designed for
+ languages with rich morphology and complex word compounding.
+
+ Nuspell is a pure C++ re-implementation of <pkg>app-text/hunspell</pkg>.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-text/nuspell/nuspell-3.0.0.ebuild b/app-text/nuspell/nuspell-3.0.0.ebuild
new file mode 100644
index 000000000000..91e224ba8293
--- /dev/null
+++ b/app-text/nuspell/nuspell-3.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="test? ( || ( MPL-1.1 GPL-2+ LGPL-2.1+ ) ) LGPL-3+"
+SLOT="0/3" # due to libnuspell.so.3
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/ronn )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ >=dev-libs/boost-1.62[icu]"
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users . Good luck!'
+ einfo
+}