summaryrefslogtreecommitdiff
path: root/app-text/nfoview/nfoview-1.27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
commit5a165c60b9b8c4847067cb83b4be7da785d01f93 (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /app-text/nfoview/nfoview-1.27.ebuild
parenta5b65c81168c90928784a1e92cda84ed5d6b9eb3 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'app-text/nfoview/nfoview-1.27.ebuild')
-rw-r--r--app-text/nfoview/nfoview-1.27.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/nfoview/nfoview-1.27.ebuild b/app-text/nfoview/nfoview-1.27.ebuild
new file mode 100644
index 000000000000..3229ddf95d7a
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1 xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext"
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}