summaryrefslogtreecommitdiff
path: root/app-text/mythes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
commit9d0673651c57438d51e18c6b8ca894d0491b2df3 (patch)
treec5b6cd187b8998d2c56d3b279ac425973d4c3a33 /app-text/mythes
parentbe21a4c281fc76681a84dd2f103e850866ce4946 (diff)
gentoo auto-resync : 24:08:2022 - 20:48:33
Diffstat (limited to 'app-text/mythes')
-rw-r--r--app-text/mythes/Manifest2
-rw-r--r--app-text/mythes/mythes-1.2.5.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/mythes/Manifest b/app-text/mythes/Manifest
index e0f3338559ee..b609009cf7b3 100644
--- a/app-text/mythes/Manifest
+++ b/app-text/mythes/Manifest
@@ -1,3 +1,5 @@
DIST mythes-1.2.4.tar.gz 4910303 BLAKE2B aa091344aebd117618d90aa574ec5e68594782511e1aa85a2d46740ecc4ff2cdf1d9f9f6de9dfd454cc0056076bdb9a21ad14d2935e39e4fdbd7753930fda605 SHA512 a04da39812bcfb1391a2cba7de73e955eafe141679ec03ed6657d03bebf360b432480d0037dff9ed72a1dfda5a70d77d44ac2bb14cdb109fd8e2a38376feee21
+DIST mythes-1.2.5.tar.xz 2891852 BLAKE2B e292e49187a9b225fdcfccb467afed0b8ce90769bbefe331d7d7f026f2dd6686543b14f3666af5b1693198467206c53da0bbd030420d87c94315f9da769f45a6 SHA512 304fd05619e0ae02c9c29d92a6ada8f4a85f41f331b87b8820728c1919f3dd9c5cd951dbef9a27e649466f94dc5daa19350c9fd09c90d49b198b73b1f9eb770e
EBUILD mythes-1.2.4-r1.ebuild 576 BLAKE2B 7a09e21daea240a26729d9bb44d060ed3ac1b6f04facbabfdf5b27153d948143db79fa363058757b9f711912d29eefdb011b532b4f6425af1d2a8b2971859076 SHA512 12521d07ce02e0604b14d3064a41a19e80f798b40dd9de999615db4bdb4ebfbdd89e3bedec0fec3588b3a5a497ec2fddcad56005f20198cbfce98352a641b414
+EBUILD mythes-1.2.5.ebuild 646 BLAKE2B 261fc3b3fd1ba096fbde79f17fa642855b0e7335d009e519f6208e925b4dfa68bd60f3508e5d18bcdd74aa3ba373b3dc728caaec3e9305d43424618c0060e436 SHA512 be6fa5fd7dd47dad03258a411a37aa90fb8aa46fb7bd70d409376bb5d466740170edf8e09182e53acac758998b65b9bbc61a1dd02f402fcd9af17aa289c2154a
MISC metadata.xml 334 BLAKE2B 3a21f7641aa43f9511100ee4a5e64ebd87a30146c27c5b60dc0dd12c3f3fc609a32b5c57f1efcd724731b5ac86a38ffff20f323bfbbcf4793c1586e8e5b9943a SHA512 ef0d056d5b5840698bda3ad0ebc3cc5aa74b51b726c838a3720db45bba8efdd78ef3c0d46d3f6b929390a3204de566d3beed15aa1c32566b75866b338ba50ccb
diff --git a/app-text/mythes/mythes-1.2.5.ebuild b/app-text/mythes/mythes-1.2.5.ebuild
new file mode 100644
index 000000000000..e9e541fbdbd0
--- /dev/null
+++ b/app-text/mythes/mythes-1.2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple thesaurus for LibreOffice"
+HOMEPAGE="https://github.com/hunspell/mythes"
+SRC_URI="https://github.com/hunspell/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="app-text/hunspell:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}