summaryrefslogtreecommitdiff
path: root/app-text/msort/msort-8.53-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
commit21dbcce41990b13f301240313be05c8d013a9258 (patch)
tree933b3c51d46dc15fefe62b03a4f41c85b7e9bb44 /app-text/msort/msort-8.53-r2.ebuild
parente53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (diff)
gentoo auto-resync : 28:01:2023 - 08:51:03
Diffstat (limited to 'app-text/msort/msort-8.53-r2.ebuild')
-rw-r--r--app-text/msort/msort-8.53-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-text/msort/msort-8.53-r2.ebuild b/app-text/msort/msort-8.53-r2.ebuild
new file mode 100644
index 000000000000..39dfa9ff4a68
--- /dev/null
+++ b/app-text/msort/msort-8.53-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A program for sorting files in sophisticated ways"
+HOMEPAGE="https://billposer.org/Software/msort.html"
+SRC_URI="https://billposer.org/Software/Downloads/${P}.tar.bz2"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+IUSE="heap +icu +libuninum"
+
+RDEPEND="dev-libs/tre
+ icu? ( dev-libs/icu:= )
+ !icu? ( dev-libs/libutf8proc:= )
+ libuninum? ( dev-libs/libuninum:= )"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-icu-build.patch"
+ "${FILESDIR}/${P}-fix-missing-limits-header.patch"
+ "${FILESDIR}/${P}-fix-segfault-on-certain-input.patch"
+ "${FILESDIR}/${P}-respect-users-cflags.patch"
+ "${FILESDIR}/${P}-configure-clang16.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable !heap allocaok)
+ $(use_enable !icu utf8proc)
+ $(use_enable libuninum uninum)
+ --disable-debugbuild
+ )
+
+ econf "${myeconfargs[@]}"
+}