summaryrefslogtreecommitdiff
path: root/app-text/mpage/files/mpage-2.5.6-fix-buildsystem.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
commitd42200bec37eef2a7478d88988ff00addd0a9202 (patch)
tree10394660b3cbe4b50173c06950b31302cd25d0d1 /app-text/mpage/files/mpage-2.5.6-fix-buildsystem.patch
parent580f05ea8f512d11e23e8da80177d27835cbdbbc (diff)
gentoo resync : 25.01.2020
Diffstat (limited to 'app-text/mpage/files/mpage-2.5.6-fix-buildsystem.patch')
-rw-r--r--app-text/mpage/files/mpage-2.5.6-fix-buildsystem.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/mpage/files/mpage-2.5.6-fix-buildsystem.patch b/app-text/mpage/files/mpage-2.5.6-fix-buildsystem.patch
new file mode 100644
index 000000000000..790d49880649
--- /dev/null
+++ b/app-text/mpage/files/mpage-2.5.6-fix-buildsystem.patch
@@ -0,0 +1,43 @@
+--- a/Makefile
++++ b/Makefile
+@@ -24,7 +24,6 @@
+ # Set this to an ANSI compatible C compiler (preferably gcc)
+ # See also system specific settings below
+ #CC=cc
+-CC=gcc
+
+ ############################################################################
+ #
+@@ -107,7 +106,7 @@
+ # If you are using gcc, you probably don't need to change anything here.
+
+ # Linux:
+-CFLAGS = -O2 -s $(DEFS) -Wall
++CPPFLAGS += $(DEFS)
+
+ # AIX (xlC on aix 4):
+ #CFLAGS = -O2 -s $(DEFS)
+@@ -134,10 +133,6 @@
+ # END OF CONFIGURATION OPTIONS
+ #
+
+-# pattern rules. Should we define these?
+-%$(O): %.c
+- $(CC) $(CFLAGS) -c -o $@ $<
+-
+
+ HEAD = mpage.h
+ DENC = encoding.h
+@@ -150,10 +145,10 @@
+ @echo Done!
+
+ mpage$(E): $(MOBJ)
+- $(CC) $(CFLAGS) -o mpage$(E) $(MOBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o mpage$(E) $(MOBJ) $(LIBS)
+
+ msample$(E): $(SOBJ)
+- $(CC) $(CFLAGS) -o msample$(E) $(SOBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o msample$(E) $(SOBJ) $(LIBS)
+
+ mpage.1: mpage.1.in
+ sed 's:PREFIX:${PREFIX}:' < mpage.1.in > mpage.1