summaryrefslogtreecommitdiff
path: root/app-text/mecab/mecab-0.996-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-01 05:41:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-01 05:41:23 +0000
commit895ff0a4d41ed3004a73b7869773a26f463c5ded (patch)
treee65c6998144819c5e9a4630a3dbca85bc3e4ff31 /app-text/mecab/mecab-0.996-r1.ebuild
parented676a605df68f67de57c1c8d70c2fef518c0701 (diff)
gentoo auto-resync : 01:03:2024 - 05:41:23
Diffstat (limited to 'app-text/mecab/mecab-0.996-r1.ebuild')
-rw-r--r--app-text/mecab/mecab-0.996-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-text/mecab/mecab-0.996-r1.ebuild b/app-text/mecab/mecab-0.996-r1.ebuild
index 9eb02cee3b92..13064cdcfed4 100644
--- a/app-text/mecab/mecab-0.996-r1.ebuild
+++ b/app-text/mecab/mecab-0.996-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
HOMEPAGE="https://taku910.github.io/mecab/"
@@ -30,16 +30,13 @@ PDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.98-iconv.patch
"${FILESDIR}"/${PN}-0.996-clang-16-register.patch
+ "${FILESDIR}"/0001-configure-remove-terrible-horrible-code-that-resets-.patch
)
HTML_DOCS=( doc/. )
src_prepare() {
default
- sed -i \
- -e "/CFLAGS/s/-O3/${CFLAGS}/" \
- -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
- configure.in
sed -i "s:/lib:/$(get_libdir):" ${PN}rc.in
mv configure.{in,ac} || die
@@ -47,6 +44,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924569
+ # https://github.com/taku910/mecab/issues/75
+ filter-lto
+
econf \
$(use_enable static-libs static) \
$(use_with unicode charset UTF-8)