summaryrefslogtreecommitdiff
path: root/app-text/mathtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/mathtex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/mathtex')
-rw-r--r--app-text/mathtex/Manifest3
-rw-r--r--app-text/mathtex/mathtex-1.04.ebuild46
-rw-r--r--app-text/mathtex/metadata.xml14
3 files changed, 63 insertions, 0 deletions
diff --git a/app-text/mathtex/Manifest b/app-text/mathtex/Manifest
new file mode 100644
index 000000000000..857c008d9281
--- /dev/null
+++ b/app-text/mathtex/Manifest
@@ -0,0 +1,3 @@
+DIST mathtex-1.04.zip 148443 BLAKE2B 6632d30536428f6f33fc13a2b5b38651f2ab7a938381166b79c009ab3d95788fc69e8ed824dae64dca00d32bb79ccd00a73b772f9aebc813d54fd6e0f18839f4 SHA512 4b299a6dc503a01d6be3182ad982e38c0b6d926f09a09bd5169f8ad2c947c020ad532b15146379b4bc2158cfceec4cb4a0b7bf902423e0a8ad9b0b0190a99601
+EBUILD mathtex-1.04.ebuild 885 BLAKE2B 1167a1ef2a7187932ff06b98d9966284a7aa8125c66d1bfc5bffffe40a661f44ec6c4869b9aa2368a932f74484c3390ec57a732b0e42cfb39f92a5275d57a54b SHA512 1c74aaa03a53c5ce6639ab5e4e960f1556aeaf3978df76eb17a9f5d9c69cfa876ef18a68b86113c518927d5239b0fa88b6a0aa9eb3300bc0cbcf48f7b296865f
+MISC metadata.xml 633 BLAKE2B 0b7f70957a2eacffe8148ad27186334c9f6a0bb4f2f0142a132eccdbbc6c1a4f96a7cb40f927c29109e2046c5bef23af4c64b1991f9fb2984f4e76ecf96f8264 SHA512 9086dbde5cbad1aebf2b0ffdf011db515befe5bff5c40e37726a0fce358f12875469d0afa70f410e273f3ec1f80a4980c77acb888b7aa5c83cd7ecb28afbb21a
diff --git a/app-text/mathtex/mathtex-1.04.ebuild b/app-text/mathtex/mathtex-1.04.ebuild
new file mode 100644
index 000000000000..c04f8dc4dfea
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.04.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="http://www.forkosh.com/mathtex.html"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="png"
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+DEPEND=""
+
+S=${WORKDIR}
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ $(use png && echo "-DPNG") \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex
+ dodoc README
+ dohtml mathtex.html
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}
diff --git a/app-text/mathtex/metadata.xml b/app-text/mathtex/metadata.xml
new file mode 100644
index 000000000000..c3330bb45b70
--- /dev/null
+++ b/app-text/mathtex/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="png">Generate png images by default instead of gif</flag>
+ </use>
+ <longdescription>MathTeX parses a LaTeX math expression and immediately emits
+ the corresponding gif (or png) image. It can be used as cgi program to embed
+ LaTeX math in your own html pages, blogs, wikis, etc. Just place an html img
+ tag in your document wherever you want to see the corresponding LaTeX
+ expression. Take a look at homepage for examples.
+ </longdescription>
+</pkgmetadata>