summaryrefslogtreecommitdiff
path: root/app-text/mandoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /app-text/mandoc
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'app-text/mandoc')
-rw-r--r--app-text/mandoc/Manifest2
-rw-r--r--app-text/mandoc/mandoc-1.14.6.ebuild124
2 files changed, 126 insertions, 0 deletions
diff --git a/app-text/mandoc/Manifest b/app-text/mandoc/Manifest
index b88f48e22c45..5e54e86880ac 100644
--- a/app-text/mandoc/Manifest
+++ b/app-text/mandoc/Manifest
@@ -2,5 +2,7 @@ AUX mandoc-1.14.5-gcc10.patch 1304 BLAKE2B d7f5c74cc4fc0da250eff19dc54c541bc1fe9
AUX mandoc-1.14.5-r1-www-install.patch 637 BLAKE2B 2550351e29db19b43de500f039f0563af8a720ef3bf7efa60ac715ca956d7dd0d13d0e092ae2749e3a76fc456eacf0260ca6fc03d324e08bf287bd8d4ac56dbf SHA512 5ed589e1322a2bbd261eb56aee8376526b80cf72eb5eafbc6e2772018c924913db0fb27eb7a50ec2509640e03e41d11e88401f76293d1d4230e777e39056c9fe
AUX mandoc.cron-r0 87 BLAKE2B 2fb4946dd2a9025f5bee78e61c11d77d6c6b9b32f9d17c11ea4f0d890e54b42817981e1cd4c568229927fd04bd0592e53ce18192f8359dded28be8c8690904f6 SHA512 74bdb16bc498d741128f1b6966afec8e21eb6899e26d20cf57cb0408ae6bdc63d75538dd355a21ae55593c359fbe707a56bbcdf6e78d557d4b53570db56fd6b3
DIST mandoc-1.14.5.tar.gz 651846 BLAKE2B 27aaf97e7226e989b33861d2a255304bb64a7cd43ca026568f4b044035241c3315a0d73673b023d9ca5b80575b8c584889832bbd86b80aaa49bb785b37559367 SHA512 848f290847f3095757f25647e6d73eb7044018b145bf6f9dc8b5db164b1421911efdc5b3b9022ec3a2c5af9687a84d5acedee810f2bd2f7caaa9242dadb2cc52
+DIST mandoc-1.14.6.tar.gz 697150 BLAKE2B e9f6087e9df977901815b1231f68e381502c7392b0ac65a060ce0ef270da3b76540a17931a076b700865a02f9ca1a8ca044a54dbf6318756931c29e6b1deb228 SHA512 54286070812a47b629f68757046d3c9a1bdd2b5d1c3b84a5c8e4cb92f1331afa745443f7238175835d8cfbe5b8dd442e00c75c3a5b5b8f8efd8d2ec8f636dad4
EBUILD mandoc-1.14.5-r1.ebuild 2954 BLAKE2B eb4b9ffbe134ea11c1fac9fce45e8f84d7cad63a0ff803b4d1fdd0cb6287a732c2c29f1114be40eb4b031d90035858edb79fd83e170b6e9de1c34e6fe7a03d96 SHA512 5f1edd81227c09a9eab1f348f1e34bbd8b23e7e5c710af31667a9cbc94943965f5411aea9594ce611b08487b4137f5627452c45ad8668b33b73f2a1d56765b87
+EBUILD mandoc-1.14.6.ebuild 2914 BLAKE2B 20b234353c2c77e7054a22eb2ba97092f60850c3ce38385e1da797d778f21324c5980f60b70105aeef70dbb229e0cf4d743cc99174afb2050f8286df83e3749f SHA512 f1e3c69ffd70178c8b9bd3cdfe01db57411a5c7050444b2a64e491fd2f640a9d2a2aa34fe5f0d6fe5ff0d769afdedfd551d75b522065aae0ca0b1ca92262ecd3
MISC metadata.xml 376 BLAKE2B c9e309738edb58e62de763b93af8b88fc0c939afa0a471a9c8e83c989bb515b1f6acdde23fb74d8d277d3e111219857f715c7107136fc82f8179907474653a75 SHA512 ce13542ac914c6dc4de722325319c7f49b93fab7b2baf0625d749c793068750800f1af55f15c199e38029a27b523b14b441fb964cf3850fb6c69607cc2a6b99d
diff --git a/app-text/mandoc/mandoc-1.14.6.ebuild b/app-text/mandoc/mandoc-1.14.6.ebuild
new file mode 100644
index 000000000000..c533b6e8298f
--- /dev/null
+++ b/app-text/mandoc/mandoc-1.14.6.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Suite of tools compiling mdoc and man"
+HOMEPAGE="https://mdocml.bsd.lv/"
+SRC_URI="https://mdocml.bsd.lv/snapshots/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="cgi system-man"
+
+RDEPEND="sys-libs/zlib
+ system-man? ( !sys-apps/man-db )
+"
+DEPEND="${RDEPEND}
+ cgi? ( sys-libs/zlib[static-libs] )
+"
+BDEPEND="
+ cgi? ( app-text/highlight )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.14.5-r1-www-install.patch
+)
+
+pkg_pretend() {
+ if use system-man ; then
+ # only support uncompressed and gzip
+ [[ -n ${PORTAGE_COMPRESS+unset} ]] && \
+ [[ "${PORTAGE_COMPRESS}" == "gzip" || "${PORTAGE_COMPRESS}" == "" ]] || \
+ ewarn "only PORTAGE_COMPRESS=gzip or '' is supported, man pages will not be indexed"
+ fi
+}
+
+src_prepare() {
+ default
+
+ # The db-install change is to support parallel installs.
+ sed -i \
+ -e '/ar rs/s:ar:$(AR):' \
+ -e '/^db-install:/s:$: base-install:' \
+ Makefile || die
+
+ # make-4.3 doesn't like the CC line (bug #706024)
+ # and "echo -n" is not portable
+ sed \
+ -e "s@^\(CC=\).*\$@\1\"$(tc-getCC)\"@" \
+ -e 's@echo -n@printf@g' \
+ -i configure || die
+
+ cat <<-EOF > "configure.local"
+ PREFIX="${EPREFIX}/usr"
+ BINDIR="${EPREFIX}/usr/bin"
+ SBINDIR="${EPREFIX}/usr/sbin"
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ MANDIR="${EPREFIX}/usr/share/man"
+ INCLUDEDIR="${EPREFIX}/usr/include/mandoc"
+ EXAMPLEDIR="${EPREFIX}/usr/share/examples/mandoc"
+ MANPATH_DEFAULT="${EPREFIX}/usr/man:${EPREFIX}/usr/share/man:${EPREFIX}/usr/local/man:${EPREFIX}/usr/local/share/man"
+
+ CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ # The STATIC variable is only used by man.cgi.
+ STATIC=
+
+ # conflicts with sys-apps/groff
+ BINM_SOELIM=msoelim
+ MANM_ROFF=mandoc_roff
+ # conflicts with sys-apps/man-pages
+ MANM_MAN=mandoc_man
+
+ # fix utf-8 locale on musl
+ $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+ EOF
+ use system-man || cat <<-EOF >> "configure.local"
+ BINM_MAN=mman
+ BINM_APROPOS=mapropos
+ BINM_WHATIS=mwhatis
+ BINM_MAKEWHATIS=mmakewhatis
+ MANM_MDOC=mandoc_mdoc
+ MANM_EQN=mandoc_eqn
+ MANM_TBL=mandoc_tbl
+ MANM_MANCONF=mman.conf
+ EOF
+ if use cgi; then
+ cp cgi.h{.example,} || die
+ fi
+ if [[ -n "${MANDOC_CGI_H}" ]]; then
+ cp "${MANDOC_CGI_H}" cgi.h || die
+ fi
+
+ # ./configure does not propagate all configure.local
+ # settings to Makefile.local settings.
+ tc-export AR
+}
+
+src_compile() {
+ default
+ use cgi && emake man.cgi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use cgi && emake DESTDIR="${D}" cgi-install www-install
+
+ if use system-man ; then
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/mandoc.cron-r0 mandoc
+ fi
+}
+
+pkg_postinst() {
+ if use system-man ; then
+ elog "Generating mandoc database"
+ makewhatis || die
+ fi
+}