summaryrefslogtreecommitdiff
path: root/app-text/lowdown
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/lowdown
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/lowdown')
-rw-r--r--app-text/lowdown/Manifest4
-rw-r--r--app-text/lowdown/files/lowdown-0.8.4-configure.patch31
-rw-r--r--app-text/lowdown/lowdown-0.8.4.ebuild37
-rw-r--r--app-text/lowdown/metadata.xml8
4 files changed, 80 insertions, 0 deletions
diff --git a/app-text/lowdown/Manifest b/app-text/lowdown/Manifest
new file mode 100644
index 000000000000..b45e25b10bc7
--- /dev/null
+++ b/app-text/lowdown/Manifest
@@ -0,0 +1,4 @@
+AUX lowdown-0.8.4-configure.patch 770 BLAKE2B c91c27b9d7a33435515214ab8701ee0c5c2ea79b074e4ba8f96d57d0ced14ca77a918258cdbcb60b6ad9522e14f298b707b69aa70aae3e89b9b061c91905da72 SHA512 b768fade94fc2369e75d4c59b13cc2a053c3edf8502e246abd0a90123a9483f2160ab470c2c162cdf439dfacf4fd184751a069d6b008775f6ffa8bf4eba85463
+DIST lowdown-0.8.4.tar.gz 520735 BLAKE2B dc66b92f285b186ca83b9fad1cccfef9b395233ef56756e9ea9071b5502cd81dc6ce2d67d7ef265dab8953010af0907cd76125cd4442cfbfc2bcf8c63e097809 SHA512 cd46ead69ed038bf3ccf848b784327d66c78dd8adbc9ae4bfee660b9b1e52844ac8c7ad0377f8f38a3fee0d2e523f979a22d6b547c7964304accef0951cfca34
+EBUILD lowdown-0.8.4.ebuild 794 BLAKE2B 48cdff865b1b252a43e4b3ecf06a2b3c391ecfac6d6fe3f47ece4ed9f14ab7f20f789a7ca3a0ee058ff0c8d3ea1014417b790e247fa12a1c9b0e4b9d9609aad2 SHA512 826fa1095d39259f218bbb82ea62caaa052f6b5cb8ea43f3ffba3fc85db7cab794c6b6258c733ff9060801d28b5e52f468caf909caa1058771adf84d6ec5aee8
+MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/app-text/lowdown/files/lowdown-0.8.4-configure.patch b/app-text/lowdown/files/lowdown-0.8.4-configure.patch
new file mode 100644
index 000000000000..ad7bcb69d631
--- /dev/null
+++ b/app-text/lowdown/files/lowdown-0.8.4-configure.patch
@@ -0,0 +1,31 @@
+diff --git a/Makefile b/Makefile
+index c2e2715..4fe977f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -143,7 +143,6 @@ install: all
+ $(INSTALL_DATA) lowdown.pc $(DESTDIR)$(LIBDIR)/pkgconfig
+ $(INSTALL_PROGRAM) lowdown $(DESTDIR)$(BINDIR)
+ $(INSTALL_PROGRAM) lowdown-diff $(DESTDIR)$(BINDIR)
+- $(INSTALL_LIB) liblowdown.a $(DESTDIR)$(LIBDIR)
+ $(INSTALL_DATA) lowdown.h $(DESTDIR)$(INCLUDEDIR)
+ for f in $(MANS) ; do \
+ name=`basename $$f .html` ; \
+diff --git a/configure b/configure
+index d1c16ab..941f185 100755
+--- a/configure
++++ b/configure
+@@ -92,12 +92,12 @@ LDADD_STATIC=
+ CPPFLAGS=
+ LDFLAGS=
+ DESTDIR=
+-PREFIX="/usr/local"
++PREFIX="/usr"
+ BINDIR=
+ SBINDIR=
+ INCLUDEDIR=
+ LIBDIR=
+-MANDIR=
++MANDIR="/usr/share/man"
+ SHAREDIR=
+ INSTALL="install"
+ INSTALL_PROGRAM=
diff --git a/app-text/lowdown/lowdown-0.8.4.ebuild b/app-text/lowdown/lowdown-0.8.4.ebuild
new file mode 100644
index 000000000000..dd0f98fee37c
--- /dev/null
+++ b/app-text/lowdown/lowdown-0.8.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ virtual/libcrypt
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.8.4-configure.patch"
+)
+
+src_configure() {
+ CC="$(tc-getCC)" ./configure || die "./configure failed"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" AR="$(tc-getAR)" $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
+src_test() {
+ emake regress
+}
diff --git a/app-text/lowdown/metadata.xml b/app-text/lowdown/metadata.xml
new file mode 100644
index 000000000000..cee379b15409
--- /dev/null
+++ b/app-text/lowdown/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>