summaryrefslogtreecommitdiff
path: root/app-text/llpp/llpp-30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-text/llpp/llpp-30.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-text/llpp/llpp-30.ebuild')
-rw-r--r--app-text/llpp/llpp-30.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-text/llpp/llpp-30.ebuild b/app-text/llpp/llpp-30.ebuild
new file mode 100644
index 000000000000..3ba1ce6fe451
--- /dev/null
+++ b/app-text/llpp/llpp-30.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs xdg-utils
+
+DESCRIPTION="graphical PDF viewer which aims to superficially resemble less(1)"
+HOMEPAGE="https://github.com/moosotc/llpp"
+SRC_URI="https://github.com/moosotc/llpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt static"
+
+LIB_DEPEND=">=app-text/mupdf-1.12.0:0=[static-libs]
+ media-libs/openjpeg:2[static-libs]
+ media-libs/fontconfig:1.0[static-libs]
+ media-libs/freetype:2[static-libs]
+ media-libs/jbig2dec[static-libs]
+ sys-libs/zlib[static-libs]
+ virtual/jpeg:0[static-libs]
+ x11-libs/libX11[static-libs]"
+RDEPEND="x11-misc/xsel
+ !static? ( ${LIB_DEPEND//\[static-libs]} )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND}
+ app-arch/bzip2[static-libs]
+ media-libs/libXcm[static-libs]
+ x11-libs/libXau[static-libs]
+ x11-libs/libXdmcp[static-libs]
+ x11-libs/libXmu[static-libs] )
+ >=dev-lang/ocaml-4.02[ocamlopt?]
+ dev-ml/lablgl[glut,ocamlopt?]"
+
+RESTRICT="!ocamlopt? ( strip )"
+
+PATCHES=( "${FILESDIR}"/${P}-keysym.patch )
+
+src_prepare() {
+ default
+
+ # use custom makefile from archlinux with minor changes
+ cp "${FILESDIR}"/Makefile "${S}" || die
+
+ # re-add desktop file removed upstream
+ cp "${FILESDIR}"/llpp.desktop "${S}"/misc || die
+}
+
+src_compile() {
+ emake -j1 VERSION=${PV} CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc README Thanks
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}