summaryrefslogtreecommitdiff
path: root/app-text/libwpg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/libwpg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/libwpg')
-rw-r--r--app-text/libwpg/Manifest3
-rw-r--r--app-text/libwpg/libwpg-0.3.2.ebuild48
-rw-r--r--app-text/libwpg/metadata.xml15
3 files changed, 66 insertions, 0 deletions
diff --git a/app-text/libwpg/Manifest b/app-text/libwpg/Manifest
new file mode 100644
index 000000000000..401d5d3e7ba2
--- /dev/null
+++ b/app-text/libwpg/Manifest
@@ -0,0 +1,3 @@
+DIST libwpg-0.3.2.tar.xz 326840 BLAKE2B a32668671bf0f6a69555dea39a522fac65f7522d7fda5cc29b8d2588fa268f1923e959bb6aa75c6ed1d4c40dde5cf458577098e4662dcee769a449ae36f13229 SHA512 f3f76a17056274b2dfd11ce4eb451411d8458b00b3f7be4fae0a932a382f247adbaae1f4f8f6005e7b84f063e415ef5ab609015ba32f779c6ab2f0404b275f3f
+EBUILD libwpg-0.3.2.ebuild 1284 BLAKE2B d2a1421146f2b0151f4ef066dc56a0afa022199f7fdcac024eb80c4b2315902a0cee1981eb9e471937fe295c4ffcf90cd54cc1d748eed19775ebfc27873ac41a SHA512 10c37c3bc9046758d110594f43182c5b0a95ea63febce3a5aac282940d8c26bc698dba5c08bfba5d7b18b2aa26291d44bd3707a1b60671a25c07d90912248d5b
+MISC metadata.xml 441 BLAKE2B c04d84af2f7d50d0c2ccf2b134b90de33ecd52a1be37e018c2c4ae071f0a54628b16c3da82398bddc4b9d53adff5f0b5da0356d12b9138b19cd4bcc7433a1255 SHA512 9725ace7bfceff2309f836bf01ab5da588f24da56d85e1130c098353e617945b820b7763cf0932e15e2b5d7ed339929fed26e8defc6a19bcad17235fe01bfc3c
diff --git a/app-text/libwpg/libwpg-0.3.2.ebuild b/app-text/libwpg/libwpg-0.3.2.ebuild
new file mode 100644
index 000000000000..46042da23141
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit alternatives
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.3"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.10[tools]
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ --program-suffix=-${SLOT} \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}
diff --git a/app-text/libwpg/metadata.xml b/app-text/libwpg/metadata.xml
new file mode 100644
index 000000000000..f341402a4a4e
--- /dev/null
+++ b/app-text/libwpg/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">libwpg</remote-id>
+ </upstream>
+</pkgmetadata>