summaryrefslogtreecommitdiff
path: root/app-text/libwpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-text/libwpd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-text/libwpd')
-rw-r--r--app-text/libwpd/Manifest3
-rw-r--r--app-text/libwpd/libwpd-0.10.2.ebuild51
-rw-r--r--app-text/libwpd/metadata.xml14
3 files changed, 68 insertions, 0 deletions
diff --git a/app-text/libwpd/Manifest b/app-text/libwpd/Manifest
new file mode 100644
index 000000000000..7d252cf491a2
--- /dev/null
+++ b/app-text/libwpd/Manifest
@@ -0,0 +1,3 @@
+DIST libwpd-0.10.2.tar.xz 536400 BLAKE2B a4ed9b8c790898436e08afd0f571c4a4b31615228248116b24bad38d07df7837982df1ffa98b0ad442cfec417fc90eb089642b32e3a094323e75fb8fc7cb8da7 SHA512 821dbc0535ebd4fa41bcf984e344e11176862676c66abebe45cf4284f8de6e6cc7629f8a605b169d034a5c2f3e2461513d61e11e549ca73b8328eb66ac3bdd79
+EBUILD libwpd-0.10.2.ebuild 1304 BLAKE2B 667017fe4e55c22281724f6bcb6971d10f135f4a28c1599388d72fcffb1a6cc49d9941120f86d9f84c83a96dc26cb6d332ea0fc61b1032e46078eb5ac70d0bbb SHA512 3c2aef394fc4ddaeb66a437697c4cd5cc37f04d989f4e2a7d654b602b2c9ee13e2f3ce413ad61cac53567f8983326ae209323e989421977ae60b035182a0f48e
+MISC metadata.xml 402 BLAKE2B 449d3fa4ee2b0be84bca5eca7708b2e318060e7d85c84369ab16923edfa4bd3a19eed80b11d3cbd7c4d9a12e2d3d07df6b0aad95f011d1ce100fd9a6fd22206c SHA512 af33c7d44f5766cadb1955928210dc6f28171eef00cfbdd96a0257226bb7eee560fb05cf58673dfbbef932600ec3e8fafa666db3f9c3ddd2bcfa5a2a90cd77f2
diff --git a/app-text/libwpd/libwpd-0.10.2.ebuild b/app-text/libwpd/libwpd-0.10.2.ebuild
new file mode 100644
index 000000000000..72fe00dc568c
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.10.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit alternatives
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.10"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips x86 ~x86-fbsd"
+IUSE="doc +tools"
+
+RDEPEND="dev-libs/librevenge"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
+ fi
+}
diff --git a/app-text/libwpd/metadata.xml b/app-text/libwpd/metadata.xml
new file mode 100644
index 000000000000..19419ec1fa6e
--- /dev/null
+++ b/app-text/libwpd/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+ <use>
+ <flag name="tools">Build file conversion tools</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">libwpd</remote-id>
+ </upstream>
+</pkgmetadata>