summaryrefslogtreecommitdiff
path: root/app-text/libpaper/libpaper-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-08 04:29:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-08 04:29:46 +0100
commit91123d2faefa2e7d77657215ec9287ae5d6dc0d7 (patch)
tree89a4d67ea84c89db1f1c03f53f83cfe59a923b47 /app-text/libpaper/libpaper-2.1.1.ebuild
parentde1079fbccb3bceb32818385f756637e266f2107 (diff)
gentoo auto-resync : 08:09:2023 - 04:29:45
Diffstat (limited to 'app-text/libpaper/libpaper-2.1.1.ebuild')
-rw-r--r--app-text/libpaper/libpaper-2.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-text/libpaper/libpaper-2.1.1.ebuild b/app-text/libpaper/libpaper-2.1.1.ebuild
new file mode 100644
index 000000000000..35123da4b6cf
--- /dev/null
+++ b/app-text/libpaper/libpaper-2.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://github.com/rrthomas/libpaper"
+SRC_URI="https://github.com/rrthomas/libpaper/releases/download/v${PV}/${P}.tar.gz"
+
+# See README.
+# paperspecs is public-domain
+LICENSE="LGPL-2.1+ GPL-3+ public-domain"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+src_configure() {
+ econf --enable-relocatable
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}