summaryrefslogtreecommitdiff
path: root/app-text/libpaper/libpaper-2.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
commit84dcbb8bcdcf5785ac3b24905c73ae4aa6bb781e (patch)
tree6f6b979013e5661ca4b3690bc9417307fdc169ce /app-text/libpaper/libpaper-2.0.4.ebuild
parent57e62db33bb33adb6593a2be7b3a5990aaf01f56 (diff)
gentoo auto-resync : 16:11:2022 - 00:53:49
Diffstat (limited to 'app-text/libpaper/libpaper-2.0.4.ebuild')
-rw-r--r--app-text/libpaper/libpaper-2.0.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/libpaper/libpaper-2.0.4.ebuild b/app-text/libpaper/libpaper-2.0.4.ebuild
new file mode 100644
index 000000000000..dcf04a114100
--- /dev/null
+++ b/app-text/libpaper/libpaper-2.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://github.com/rrthomas/libpaper"
+SRC_URI="https://github.com/rrthomas/libpaper/releases/download/v${PV}/${P}.tar.gz"
+
+# See README.
+# paperspecs is public-domain
+LICENSE="LGPL-2.1+ GPL-3+ public-domain"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="sys-apps/help2man"
+
+# False positive (runs within a conditional)
+QA_AM_MAINTAINER_MODE=".*help2man.*"
+
+src_configure() {
+ econf --enable-relocatable
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}