summaryrefslogtreecommitdiff
path: root/app-text/libpaper/libpaper-1.1.28.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-text/libpaper/libpaper-1.1.28.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-text/libpaper/libpaper-1.1.28.ebuild')
-rw-r--r--app-text/libpaper/libpaper-1.1.28.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/libpaper/libpaper-1.1.28.ebuild b/app-text/libpaper/libpaper-1.1.28.ebuild
new file mode 100644
index 000000000000..72c0661922cf
--- /dev/null
+++ b/app-text/libpaper/libpaper-1.1.28.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://packages.debian.org/unstable/source/libpaper"
+SRC_URI="mirror://debian/pool/main/libp/libpaper/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DOCS=( README ChangeLog debian/changelog )
+
+src_prepare() {
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+ default
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ einstalldocs
+
+ dodir /etc
+ (paperconf 2>/dev/null || echo a4) > "${ED}"/etc/papersize \
+ || die "papersize config failed"
+
+ if ! has_version app-text/libpaper ; then
+ echo
+ elog "run e.g. \"paperconfig -p letter\" as root to use letter-pagesizes"
+ echo
+ fi
+}