summaryrefslogtreecommitdiff
path: root/app-text/libpaper/libpaper-1.1.24_p5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/libpaper/libpaper-1.1.24_p5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/libpaper/libpaper-1.1.24_p5.ebuild')
-rw-r--r--app-text/libpaper/libpaper-1.1.24_p5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/libpaper/libpaper-1.1.24_p5.ebuild b/app-text/libpaper/libpaper-1.1.24_p5.ebuild
new file mode 100644
index 000000000000..2d38d6de8929
--- /dev/null
+++ b/app-text/libpaper/libpaper-1.1.24_p5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+MY_PV=${PV/_p/+nmu}
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="http://packages.debian.org/unstable/source/libpaper"
+SRC_URI="mirror://debian/pool/main/libp/libpaper/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+RDEPEND="abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20130224-r10
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS=( README ChangeLog debian/changelog )
+
+src_prepare() {
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+ default
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ einstalldocs
+
+ dodir /etc
+ (paperconf 2>/dev/null || echo a4) > "${ED}"/etc/papersize \
+ || die "papersize config failed"
+
+ if ! has_version app-text/libpaper ; then
+ echo
+ elog "run e.g. \"paperconfig -p letter\" as root to use letter-pagesizes"
+ echo
+ fi
+}