summaryrefslogtreecommitdiff
path: root/app-text/libodfgen/libodfgen-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-text/libodfgen/libodfgen-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-text/libodfgen/libodfgen-9999.ebuild')
-rw-r--r--app-text/libodfgen/libodfgen-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-text/libodfgen/libodfgen-9999.ebuild b/app-text/libodfgen/libodfgen-9999.ebuild
new file mode 100644
index 000000000000..3e7137661d27
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/libodfgen"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=c++11 \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}