summaryrefslogtreecommitdiff
path: root/app-text/libmwaw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-text/libmwaw
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest4
-rw-r--r--app-text/libmwaw/libmwaw-0.3.17.ebuild52
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild8
3 files changed, 59 insertions, 5 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index 1578fe2895ba..ff473167ffe8 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1,4 +1,6 @@
DIST libmwaw-0.3.16.tar.xz 1306872 BLAKE2B 29c39ddb2cfe63116cbe7152a4dc3b7f16d402745c0dffd67c07dc42fa1ddee71f391695ead2519b3e1da206e8f437fbd24fa78ce1decfaa55e38a13d5d144e8 SHA512 c043d77e4b0efd7da594c1e370f24ee2d85afcb8a5e28179b4c3d76c8b7925f41ca5361bee12b35af732ef39f34fac46aa3636cb27c179ef9bb2b6feeaa19b0a
+DIST libmwaw-0.3.17.tar.xz 1349700 BLAKE2B 4b5ba8d5133144973609dfbd273ca36cc95e52608c78f6143f7c4283bc2bc6d7ceb22836a693d64fa7408957a3b02a7c9d0a5ab9235aa2d0b9725170441babfc SHA512 c3a1bb079d7e74cd7a23de1501730be21b1b089ef6d4f81ee0001775483c6346da3105b0d67f75523e4e088987bc92b97acb056ec7fc11bb29047109a1cf5ac4
EBUILD libmwaw-0.3.16.ebuild 1032 BLAKE2B 24628116e25ae32185374858f2bc466eaff8c435ef4974789c204672551d939a4e19483ea610bb2fc141978c71fbcd3237fac386fa7928546513671a9bf5777f SHA512 9c6ef217f07414f0806f17aa9b13f2c32bf931f2b61fd85f4021d47c9082ffabe3b534de73870fbacfe13322d0a2b9e102f246445bc10b4035662782d134e151
-EBUILD libmwaw-9999.ebuild 1027 BLAKE2B e51984196fe26cf9e7ba8ebe2e6de35c58443d3db82a65ee5d0358ac05f7905227670e05106e89d52ecb264f1e3833fe38917fce36a1fb6a2449228d90409d82 SHA512 9b530edcb03829b26715e09c5b99dc5f08bda876317813bf4589a7366a4bf20c5e2f0604792d103d6f50f2f7c4439a19dc60e362bef8627026508910eabf7837
+EBUILD libmwaw-0.3.17.ebuild 1004 BLAKE2B bd99841d18279477318ce13e9c80907572ecbb1de67ec738bf32afda9df36ed9e4d0e6ec695a386e535b41e19d0088f2635778448a0b6480bdc71c84da44a62e SHA512 f822bef23ebbe99c097d20a6b312014abb2091e61a54f4a8cf184252f13db23deccc3c0ac6b09f68309d4cf95479a58be6a8a9ba508dfd30e327ea6a5958fb95
+EBUILD libmwaw-9999.ebuild 1007 BLAKE2B 0d5cee2920040a56940cf0e916f4734433875c73fe541d7918c3bdaea0d4820a40975a0d67c154ef23a02f6b70e3fe49b9ceaaacc79cfd82c6ee74d552f455e4 SHA512 d65054c2dbd389041d5c55bfa8f8819507987ef862474f218ba6115d818dda293ecc7473f67b33cdd89679f706a7b2d717e22f6c071e922d79aeea1a37917a16
MISC metadata.xml 403 BLAKE2B cbddacc98e4f22e521d739150ee4044b93c297dbd6d220a445192a3d1a6316491d6ed72ada8bd138c287133fcaf1b3d5ce580e68dd3ec071d36abbc1b05b4b6d SHA512 12cebd7bdaff6a793598f40cb11f4ae6681dcb29b18ecb7db92681abf1f6d4ce0281ae292c84106a143c0ff5ff3395e37604b3576c6a479001fc351dba10c7ed
diff --git a/app-text/libmwaw/libmwaw-0.3.17.ebuild b/app-text/libmwaw/libmwaw-0.3.17.ebuild
new file mode 100644
index 000000000000..094644ec7197
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-static
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index cc207bd575ba..bd259959df53 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,7 @@ HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="doc static-libs tools"
+IUSE="doc tools"
BDEPEND="
sys-devel/libtool
@@ -38,9 +38,9 @@ src_configure() {
# zip is hard enabled as the zlib is dep on the rdeps anyway
local myeconfargs=(
--enable-zip
+ --disable-static
--disable-werror
$(use_with doc docs)
- $(use_enable static-libs static)
$(use_enable tools)
)
econf "${myeconfargs[@]}"
@@ -48,5 +48,5 @@ src_configure() {
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}