summaryrefslogtreecommitdiff
path: root/app-text/libmwaw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-text/libmwaw
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest2
-rw-r--r--app-text/libmwaw/libmwaw-0.3.18.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index 0ceed8bf5a3a..d0718ef37f3a 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1,4 +1,6 @@
DIST libmwaw-0.3.17.tar.xz 1349700 BLAKE2B 4b5ba8d5133144973609dfbd273ca36cc95e52608c78f6143f7c4283bc2bc6d7ceb22836a693d64fa7408957a3b02a7c9d0a5ab9235aa2d0b9725170441babfc SHA512 c3a1bb079d7e74cd7a23de1501730be21b1b089ef6d4f81ee0001775483c6346da3105b0d67f75523e4e088987bc92b97acb056ec7fc11bb29047109a1cf5ac4
+DIST libmwaw-0.3.18.tar.xz 1382328 BLAKE2B eae75e24826a963032d866be1834221850a762447495a209ad1fe268c1072c877e4c19843d61e2e4d9322a48a03b459fa9a4cc734af0eabbb09813ff9626e466 SHA512 4666c0dcc567e3e4c0ae5d9651a7003d2f32acda841bd1e297d46e566430c9227588e29b219987c56f1347f6e5656b52b00d8d6d8fa7902e19d175505e345b7e
EBUILD libmwaw-0.3.17.ebuild 1004 BLAKE2B bd99841d18279477318ce13e9c80907572ecbb1de67ec738bf32afda9df36ed9e4d0e6ec695a386e535b41e19d0088f2635778448a0b6480bdc71c84da44a62e SHA512 f822bef23ebbe99c097d20a6b312014abb2091e61a54f4a8cf184252f13db23deccc3c0ac6b09f68309d4cf95479a58be6a8a9ba508dfd30e327ea6a5958fb95
+EBUILD libmwaw-0.3.18.ebuild 1007 BLAKE2B 2042912c93c84d2c590f2f6d11ee0b936f71c8d6811425f3cc00a3ec2b18edd44714cdcd69467acc84da93e2a0096f86a32df4a1d0e5e847b49a1986c718ddbb SHA512 03834bd3781edd22c3c71008aec707a855e28e54227ffe2e54c52c8c48639fb283f472b32e646484f9d6679fae25c585a95fc013c00d09583bd49f55d7a44427
EBUILD libmwaw-9999.ebuild 1007 BLAKE2B 0d5cee2920040a56940cf0e916f4734433875c73fe541d7918c3bdaea0d4820a40975a0d67c154ef23a02f6b70e3fe49b9ceaaacc79cfd82c6ee74d552f455e4 SHA512 d65054c2dbd389041d5c55bfa8f8819507987ef862474f218ba6115d818dda293ecc7473f67b33cdd89679f706a7b2d717e22f6c071e922d79aeea1a37917a16
MISC metadata.xml 403 BLAKE2B cbddacc98e4f22e521d739150ee4044b93c297dbd6d220a445192a3d1a6316491d6ed72ada8bd138c287133fcaf1b3d5ce580e68dd3ec071d36abbc1b05b4b6d SHA512 12cebd7bdaff6a793598f40cb11f4ae6681dcb29b18ecb7db92681abf1f6d4ce0281ae292c84106a143c0ff5ff3395e37604b3576c6a479001fc351dba10c7ed
diff --git a/app-text/libmwaw/libmwaw-0.3.18.ebuild b/app-text/libmwaw/libmwaw-0.3.18.ebuild
new file mode 100644
index 000000000000..7363e33a0479
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.18.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-static
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}