summaryrefslogtreecommitdiff
path: root/app-text/libmwaw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 17:26:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 17:26:08 +0100
commit3cf27339901a7ca15df33f6ea134daa93888d5d0 (patch)
treed0f451df94a8ce90e3e81be8816e5f3ed8e62138 /app-text/libmwaw
parentf6a034d922bf54efeaa781fcb5388b325b90d945 (diff)
gentoo auto-resync : 03:05:2023 - 17:26:08
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest4
-rw-r--r--app-text/libmwaw/libmwaw-0.3.22.ebuild55
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild4
3 files changed, 60 insertions, 3 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index f157a6e4e59a..47761a38d301 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1,4 +1,6 @@
DIST libmwaw-0.3.21.tar.xz 1457212 BLAKE2B 19e0893c186f273f5743a397da895f653cca1300febcac90353951c6ca66405c2481aac6083017f4ec00a31ee0f08e8e77dc579019396e23930a091de2d8903a SHA512 1b6aab4f3e76d1d7a3c15cc175642c62f826172c9fdef558617b87a98d056a05d817caaccdc199197670f84ada448b65cce61f5254ed8e1d7634a637d3367384
+DIST libmwaw-0.3.22.tar.xz 1476620 BLAKE2B 8133dbd06fdde5caabe9284fd0535e97335385a96ceea4ea9bc1d6f2a28f14f22f6943d71ee6631cb8d67c8791b56ed3d928bb18c723c7aec0b8cf7faf8427d7 SHA512 8682e7006430764cb825cd0bf4822ff42ea3035606e13a804afb9fa3c6dc583f34ae24cea226c1d31eae95224525289801c0afa3853adc6ab396bb9df34a60b4
EBUILD libmwaw-0.3.21.ebuild 1027 BLAKE2B 566b95385cd77da4c5b5fd8b0403149f8b417526b0284dc90463b157f483eb9fed5439acb80d73343ea16002a0331e3febf55c9ec65c8aac76221803f844b077 SHA512 4ef0bdda09e075d8c0b1fea8c74677cb6c1fa2cf655a69344af7d73afd4ab786d3d12f1b49afcf1415e3ad13152362c512de2ff5abcbc2ef8c250fd5df24bc5e
-EBUILD libmwaw-9999.ebuild 1023 BLAKE2B 145b03e8e06036d50d8a6970edeabf1b60e6e90e8f0126599f3096da6d466205ad8681b1f49f454b59822d749d2e0f2f84ccebe0c12a39d8d53a660f478f6a71 SHA512 d871bfdf6611596cab7a31b62bcb72a2f51bdd985f1b986719e8561df0b4379ff0fac13e13b4528b32d510798cfe27daeeca2ed734bb5015c080470552a2cf99
+EBUILD libmwaw-0.3.22.ebuild 1030 BLAKE2B 6f828ca72e7cad536f9eba0699bbdc221127b374190f67657f9fef6eb2f3d60481e47bc2c885b51c8e59252b54d8a2cfc49d8b147fc3f5920a835e7761d3a96e SHA512 176d67db6aba7cbac9fa668a5384287cf165bb9336ac69f00c7f6ef0b2d256d9f48a11a6bdc88eb46715c5270b25b0d894a909d74c5ef7c603468c1c31cc89f3
+EBUILD libmwaw-9999.ebuild 1030 BLAKE2B 6f828ca72e7cad536f9eba0699bbdc221127b374190f67657f9fef6eb2f3d60481e47bc2c885b51c8e59252b54d8a2cfc49d8b147fc3f5920a835e7761d3a96e SHA512 176d67db6aba7cbac9fa668a5384287cf165bb9336ac69f00c7f6ef0b2d256d9f48a11a6bdc88eb46715c5270b25b0d894a909d74c5ef7c603468c1c31cc89f3
MISC metadata.xml 404 BLAKE2B 95ac1c73023ff52b4a0d1754f9d37b6c2ffd82f49f16122058f853e40ce15dd9b2fbe6ecc24bdf86e82addc27b4a6f9cd7478560fde845b696f62a1645abdca7 SHA512 858235729f5091f06699f4b32ff14890c139c5e0adff30172da79e3fec4b4452e8529c401a0273b1799706e0ade449451f10b84555ade12022bf62e37098ac07
diff --git a/app-text/libmwaw/libmwaw-0.3.22.ebuild b/app-text/libmwaw/libmwaw-0.3.22.ebuild
new file mode 100644
index 000000000000..2c2ad8452cba
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.22.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+
+ # Refresh stale libtool, bug #814512
+ eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index 52053156b9ad..2c2ad8452cba 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi
DESCRIPTION="Library parsing many pre-OSX MAC text formats"